Flirc just stopped working

This is super weird. About a month ago, Flirc stopped working completely on my raspberry 4b. Following is the list of all the things that I’ve tried:

  • Reinstall ropiee from scratch (more times than I can remember), using several different memory cards, with or without a case, trying several different power sources.
  • Restart Roon service (running on a Synology DS1019+).
  • Reinstall Roon service.
  • Buy a new Flirc and try that. Both old and new work just fine on everything else). The configuration is the exact same I had when it was working on both.
  • Buy a new raspberry 4b and repeat the previous steps.
  • Rename zones several times.
  • Try several DACS, connected directly or using a USB HUB.
  • I even tried wired network vs. wifi, so I’m pretty much throwing everything at the wall to see what sticks.

And yes, I’m 100% sure the zones match between Roon and ropieee and Flirc is configured properly. Remember it stopped working on its own, I didn’t touch a thing to make it happen.

Things I can think of that I haven’t done yet (waiting for some advice first):

  • SSH. I don’t see the point after everything else I’ve tried.
  • Rebuild Roon library
  • Change NAS (and I’m not gonna try it either, I see no reason to do so)
  • Downgrade Roon to a previous version.

It’s driving me crazy. I listen to music before going to sleep, and without a working remote, it’s impossible. This thing is affecting my quality of life on top of my nerves.

Any suggestions? An exorcise maybe?


That might well work… :joy:

I read you trying a new Flirc, but I see no mention of trying to (re)program it nor the old one - but you did that, right?

Have you enabled RoPieee’s remote extension in Roon?

Maybe send Harry a feedback packet for giggles :rofl:

Isn’t there a problem with Roon and latest Synology OS update? If you updated your Synology recently that might be it.

Thanks to everyone for the responses.

I noticed the timing was more or less aligned with the launch of 1.8, making me think it is a Roon problem, no a Synology one. I upgraded the core to version 2021-03-08 as soon as it came out with my fingers crossed even though I didn’t find any mention on the release notes. It still didn’t work. So, after crying in a corner for a little bit, I decided to start again from scratch under the suspicion that maybe something stayed messed up from all the crap I tried since the last full reset. Turns out, I might be right because now is working again.

Yayyy! \o/