Focal Arche + Roon Nucleus+ = Heart Break [SOLVED]

I was super excited when I scored a great deal on a Focal Arche headphone Amp/DAC on Black Friday. It finally arrived and it immediately replaced my beloved Sony TA-ZH1ES, which had been connected to my Nucleus+ via USB.

Imagine my disappointment when it was unable to play any soundtrack. It would just skip records, one after the other. I checked the Focal website for an updated firmware, but couldn’t fine one.

I’m hoping this is an easy issue to fix and I’d be happy to collaborate with anyone to get to the bottom of it.

Equipment: Roon Nucleus+, Focal Arche
Connection: Direct USB

So the Focal site was not useful. I looked at the US and FR sites and could not find any links to new firmware.

However, after Googling, I found that the Moon Audio sites has a very useful firmware upgrade page for the Focal Arche! Focal Arche DAC Amplifier Update - Moon Audio (

I followed the procedure as described and lo-and-behold it’s working now!!! Oddly enough, before the update, I have running firmware 1.1.08 and after the firmware update it was still the same!?! Confusing, but I’m happy it’s working now!

1 Like

It was probably an update for the USB module.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.