Focus not seeing albums in watched Music Folder

Innuos Zen Mk3 1TB 1.4.7 Roon Core 1.8 (764) Remote M1 Macbook Air 1.8 (764)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

All ethernet from router through x1 Netgear unmanaged switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Ethernet from Innuos Zen Mk3 to Naim NDX 2.

Description Of Issue


I just been exploring 1.8 over the last few weeks and have noticed that when I focus on my Innuos located Music Folder under Storage Locations some of the stored albums are missing. They are physically there on the HDD (confirmed by looking at the folder).


Elton John Mad Man Across the Water on HDD and a Qobuz version. It can be seen under versions but not when looking at the Music Folder using focus. If the Music Folder version is made primary or the Qobuz version is deleted, it suddenly appears under Music Folder focus.

Also, my Album numbers don’t seem to match.

I’ve rebooted everything. I’ve forced a re-scan of the Music Library and I’ve performed Library Maintainence.

Im hoping this is a case of a 50 year old not understanding how to use Roon!

Thanks everyone,


Hi Daz,

just another user here. In settings/general how do you have Show Hidden set?

That may be the reason for the difference. If the albums are set to not show hidden, then the One count will be all albums, and the other albums shown (not counting the hidden ones). As you can see, I run Roon with the option set to SHOW all albums


Thanks for a speedy reply.

I toggled Show Hidden and instantly all my Music Library albums appeared.

I’ll toggle it whenever I want to see only my HDD albums.

Thank you.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hey @Darren_Jones,

Thanks for bringing this up! I’m sorry we weren’t able to reply on the day you posted, but so much later :pleading_face:

I’m very happy to see that switching the Show hidden tracks and albums toggle resolved this for you. Many thanks to @Rugby for the help :pray: