Focus on local files doesn't show all local files

Roon Core Machine

Intel NUC7 i7, 16GB RAM running Debian 11 and Linux core

Networking Gear & Setup Details

N/A

Connected Audio Devices

N/A

Number of Tracks in Library

50K tracks

Description of Issue

This is probably a duplicate, but I can’t find another report so. If you use focus to find albums on local storage, it doesn’t display local files with a matching Qobuz version in your library. For a concrete example, I have “Grateful Dead, Workingman’s Dead” as a CD rip locally but also the Qobuz 96K Studio version as a streaming copy in my library. The Qobuz version is my “primary” version. When I use focus storage location and select the root of local storage, there’s no sign of my CD ripped copy. If I make my local copy the “primary”, then it shows up. This might be intended behaviour, but when I focus on local, I expect to see all of my local content.

Duplicates get hidden and only the primary version remains visible. Hidden means what it implies. Hidden files don’t get displayed, also not in result sets of Focus or Search. You need to enable (at least temporary) the “Show hidden tracks and albums” option in Settings to be able to do what you want.

From FAQ: How does Roon handle multiple versions of the same album?:

When browsing your library Roon hides duplicates by default, but you can turn this off at any time from the General tab of Settings by toggling the Show Hidden Tracks And Albums option.

3 Likes

The documentation expert strikes again :slight_smile: thanks @BlackJack

2 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.