Folders beginning with ''.'' not imported

I was scrolling through my Metallica albums when I found out that …And Justice For All was missing. I was quite surprised because that album appears just fine in JRiver.

After some investigation, it seems that Roon does not import folders beginning with “.”

Anyone can reproduce this ?

Thanks !

Setup : Music files on Synology DS413j NAS -­> ethernet -> Roon 1.3 on Windows 10 desktop PC (using mapped drives for NAS files)

Roon skips some directories for stability/performance type reasons. Here’s a KB article:

Roon 1.3 made it possible to stop ignoring folders starting with a “.”, although we do ignore them by default. To change this on your system, go to settings -> storage -> 3 dots menu for the folder you want to change. That will bring up a screen that looks like this:

remove the “/.;” from the “Ignored Paths” at the bottom, click save, and wait for Roon to re-scan everything.


Do you happen to have ZZTop’s “Recycler” album as well? Not sure whether this one’s still covered by Roon not scraping folders with Recycle in the folder name.

No issue with Recycler here. Problem “Eliminated” :wink:


Roon 1.3 truly is La Futura. :grinning:

If only another chap would join in then there would be three of us :sunglasses::clown_face::cowboy_hat_face:

Tres Hombres. :sunglasses::sunglasses::sunglasses:


Thanks ben !

Sorry, I should’ve checked Roon settings in details.

You’re welcome, and no need to apologize, this is what we’re here for.

I’m just glad my work in making our path ignoring less aggressive is helping people.


Hi Ben,

As you suggested, I removed the “/.;” from the “Ignored Paths” and saved the settings.

I also forced a rescan, but Roon still don’t pick folders beginning with “.”.

Any ideas ?

thx !

Could you try removing the "."s? There can’t be too many of these.

Hi @ben,
I assume that the leading slash refers to the configured ‘Folder’ path. Would this then mean that ‘/.’ only ignores top level directories that start with a ‘.’?

I will try this tonight.

Thx !

This isn’t quite right. The ignore patterns are just use a with a simple string contains test. This means that a slash of the appropriate direction (’/’ on Mac/Linux cores, ‘’ on Windows cores) at the start of the pattern means “match directory names beginning with this”, and at the end means “match directory names ending with this”. The ‘;’ is just a seperator between patterns.

In other news, while looking at a related bug I just found a line in our code that ignored all directory or file names starting with a ‘.’ regardless of all the normal ignoring mechanisms. The fact that removing the “/.;” from the ignore patterns didn’t work was just a bug, which should be fixed for the next build.

Hi Ben,

Good news !

Thanks !

It had to work differently, thanks for explaining.
Does this also mean that wildcard characters are not supported?

Correct, at this time we don’t support any kind of wildcard characters. I don’t think we really want to either, those patterns are hard enough to explain as it is.


Your explanation may be a good addition for the FAQ.

@ben files/folders with a name that starts with a “.” on Mac OS are invisible so… please let Roon keep ignoring them :wink:

By default, all watched folders in Roon come with a pattern like “/.” or “.” in the ignore patterns to ignore files and folders starting with a “.” on all systems. We’ve just made it so that in 1.3 you can turn that off if you want to for whatever reason.

1 Like