Force Crossover genre to display composer?

On my unidentified albums marked Crossover genre, composer is not displayed in the album’s view.

As a workaround, I changed genre to Classical everywhere. This solves the problem.

Is there an alternative that forces the display of composer on unidentified albums yet preserves Crossover?

Thank you,

Try “Always” on this Setting:

Thank you Geoff that works.