Forcing "With... "?

How do I force an album to appear in the “With…” section of an artist view? e.g. see picture (when viewing “Ben Folds” his work with Ben FOlds Five has it’s own section. Have been playing around with ‘primary artist’ and ‘group member’ in the metadata area of albums but to no avail. Thanks

The artist needs to be listed as a Guest Artist with a Primary Artist in the Album Editor.

Thanks @Martin_Webster but not sure i follow. Couldn’t get it to work.

Hopefully the following example, with screenshots, showing the artist Emmylou Harris With Patty Griffin will demonstrate:

Selecting the first album by Patty Griffin …

Open the album editor by clicking on the vertical ellipsis and choose Edit to enable or disable file tags. If tags aren’t present they must be added with a file tag editor.

Use the Album Editor to add Credits with the term Guest Artist.


Thanks again @Martin_Webster. Crystal clear but still no luck. Looking at John Lennon who has a “With The Beatles” (obviously) I see that he’s referenced as a Member of Attributed Artist in the metadata of White Album. I tried that, as well as Group Member, Guest Artist and Primary Artist but no luck. I’m doing this on a pretty obscure group and artist so maybe there’s some conflicting data stopping it but i cleaned out the file data as much as possible.

Is it that the person is listed as a member in the details displayed for a group above Top Tracks? I see the four are all listed there. And we’re not able to add members for a band I believe??

Sorry, I should have been clearer. Roon will only list Credits if they exist as file tags; you can only enable/ disable in Roon. Remember, Roon doesn’t alter your files. You’ll need to use a tag editor.

Ah ha! Wonderful thanks so much. Just reading up on the tags. And thanks for the clear instructions. Hopefully the devs can turn it into a FAQ note. Just starting to preen my collection in Roon and loving the power.

1 Like