Found two songs that stop mid-track with RAAT to Naim Uniti Atom

Roon Core Machine

Nucleus+
Roon Server: Version 108 (build 882) stable
Internal Storage: Samsung SSD 860
Ethernet Connection

Networking Gear & Setup Details

Wireless Router: ASUS RT-AC68U
Nucleus+: Ethernet
Naim Atom: Wi-Fi 5GHz

Connected Audio Devices

Naim Uniti Atom
Firmware 3.8.0.5355
Roon Device Settings: Default
Roon DSP: Default
Roon Volume leveling: Off

Number of Tracks in Library

5,786 tracks

Description of Issue

I have found two 96kHZ 24bit songs that will not play all the way through when using RAAT from the Nucleus+ to my Atom.

  1. come on songs by Adrianne Lenker
  2. Artangels on Art Angels by Grimes

I use Roon with my Atom 99% of the time. I rarely have any issues. However, if I try to play the above two tracks, they always stop mid-track. It took me a while to narrow that down, but that is currently the case. I’m certain it’s not a network issue (unless you prove me wrong) because of the consistency of it always stopping for those two tracks, but not others. The other oddity is that the tracks don’t always stop at the same time. It’s generally in the same range, but it can vary.

I have had this issue for several months, maybe even getting close to a year. It is not directly related to the recent firmware updates for both systems - Roon (108 build 882) or Atom (3.8.0.5355). I was hoping the recent firmware updates on both systems would fix this issue, but that didn’t happen.

I attempted to isolate the issue and I do believe it is with RAAT. However, I can’t tell if it’s on the Nucleus+ side or Atom side. Initially I was streaming from Roon + Qobuz when having this issue. I eventually purchased the same albums directly from Qobuz. I placed them onto the Nucleus+ internal storage, as well as a USB. I did this to prove the best I could that the tracks I’m testing with are not corrupt.

For independent testing, I used the Qobuz client built directly into the Atom. I also plugged the USB directly into the Atom for additional tests.

  Test results with 'come' and 'Artangels' 96kHz 24bit
  | Source           | Transport             | Result               |
  |------------------+-----------------------+----------------------|
  | Qobuz Streaming  | Roon RAAT             | Stops mid-track      |
  | Internal Storage | Roon RAAT             | Stops mid-track      |
  | Qobuz Streaming  | Roon Chromecast       | Plays complete track |
  | Internal Storage | Roon Chromecast       | Plays complete track |
  | Qobuz Streaming  | Atom Qobuz Client     | Plays complete track |
  | USB              | USB plugged into Atom | Plays complete track |

I do have logs capturing the results of my testing, and I can easily recreate the results if needed. Here are relevant portions of the log showing Artangels stopped/paused at 0:24.

  12/19 17:28:46 Trace: [Atom (RAAT)] [Lossless, 24/96 FLAC => 24/96] [100% buf] [PLAYING @ 0:19/4:07] Artangels - Grimes
  12/19 17:28:48 Info: [stats] 27790mb Virtual, 1651mb Physical, 304mb Managed, 299 Handles, 85 Threads
  12/19 17:28:51 Trace: [Naim Audio Uniti Atom @ 192.168.1.111:45102] [raatclient] GOT [17] {"status":"Ended"}
  12/19 17:28:51 Trace: [raat] [Naim Audio Uniti Atom @ 192.168.1.111:45102] => Disconnected
  12/19 17:28:51 Trace: [raat] [Naim Audio Uniti Atom @ 192.168.1.111:45102] lost client connection. Retrying
  ...
  12/19 17:28:51 Trace: [Atom (RAAT)] [Lossless, 24/96 FLAC => 24/96] [100% buf] [PLAYING @ 0:24/4:07] Artangels - Grimes
  12/19 17:28:51 Trace: [Naim Audio Uniti Atom @ 192.168.1.111:45102] [raatclient] GOT [5] {"status":"Success","action":"Changed","controls":{"source":{"info":{},"is_standby_supported":true,"value":"selected"},"volume":{"info":{},"step":1.0,"max":100.0,"type":"number","min":0.0,"mute":false,"value":32}}}
  12/19 17:28:51 Trace: [zone Atom (RAAT)] Loading
  12/19 17:28:51 Trace: [zone Atom (RAAT)] Suspend
  12/19 17:28:51 Info: [zone Atom (RAAT)] Canceling Pending Sleep
  12/19 17:28:51 Trace: [Atom (RAAT)] [zoneplayer/raat] Endpoint Naim Audio Uniti Atom Initial State: Idle
  12/19 17:28:51 Info: [transport] created zone Atom (RAAT)
  12/19 17:28:51 Info: [transport]     with endpoint Naim Audio Uniti Atom (23:1:71472e58-94a5-4316-b343-15454ab590d7) [IsAvailable=True]
  12/19 17:28:51 Trace: [Atom (RAAT)] [Lossless, 24/96 FLAC => 24/96] [100% buf] [STOPPED @ 0:00]
  12/19 17:28:51 Trace: [zone Atom (RAAT)] Loaded Queue=4 Tracks Swim=Inactive AutoSwim=False Loop=Disabled Shuffle=False
  12/19 17:28:51 Trace: [Atom (RAAT)] [Lossless, 24/96 FLAC => 24/96] [100% buf] [PAUSED @ 0:24/4:07] Artangels - Grimes

Please let me know if you need any additional information, and if I should also reach out to Naim on this issue. Thanks!

Hello @support, I’m replying to keep this topic alive. I believe I have possibly found an edge case bug with my Atom (Roon Ready) and RAAT. As mentioned above, I’m not certain if the issue is on the server or client side. If it’s a client-side issue on the Atom, I can submit a ticket with them. Thanks.

Both tracks play fine on my setup (Ropieee).

I have the Atom and own the Adrianne Lenker Album never had an issue with it stopping at all, I listened on Qobuz before.i bought it ana don’t remember any issues their either. So you have an edge case for sure.

Hi @gsuzor91,

I just played both tracks via RAAT and each were able to play through completely. I’m not using a Naim endpoint however.

As a test, can you please try to play the tracks on a different endpoint, like one of your remotes and tell us what happens? That will help us to determine if it could be the Naim. Thanks!

I also just played 96kHz 24bit Qobuz track on my Naim Uniti Atom, wired network connection, without any issues.

Also played the “Songs” 96kHz 24bit Qobuz track by Adrianne Lenker without any issues.

If you can set up the Uniti Atom with a wired network connection, that would really help determine if it is just a WiFi issue or not.

Another troubleshooting attempt can be to remove the albums from your Favorites in Qobuz, then remove them from Roon, and after confirming, add them back. May be corrupted files in your database.

1 Like

Hi @jamie, I just tested on my PC (wifi) with both Realtek ASIO and Realtek WASAPI (exclusive mode). Not sure why I didn’t think of using my pc before to test. I tested on my android previously, but the signal path shows a sample rate conversion down to 48kHz, so didn’t think it was a fair comparison. With the PC, the signal path shows Lossless as it does for the Atom, so a better comparison. I have a playlist set up to make sure I play everything in sequence.

  1. ‘songs’ streamed from Qobuz
  2. ‘songs’ from local storage on nucleus
  3. ‘Artangels’ streamed from Qobuz
  4. ‘Artangels’ from local storage on nucleus

All of these in 96kHz 24bit played just fine with ASIO and WASAPI on my PC via RAAT.

I think that rules out the tip Techru gave to remove albums and add them back in case they are corrupt. I have not tried a wired network connection though. My initial thinking was this was not a wifi issue because those tracks fail every time on the Atom when played with RAAT, while I can play other albums all day long without an issue. However, since I know that in IT if it can happen it will happen, I will see if I can get the Atom wired and see what happens. (May take a few days.)

Well, this is interesting (keep reading). Here’s what I did today:

  1. Queued up 11 albums / 150 tracks / 9 h 36 m of 96kHz 24bit worth of tracks. (RAAT over 5GHz wifi)
    • Only 1 track stopped similar to songs or Artangels.
    • Everything else played without an issue.
  2. Queued up my 4 track Troubleshooting playlist. (RAAT over 5GHz wifi)
    a. ‘songs’ streamed from Qobuz
    b. ‘songs’ from local storage on nucleus
    c. ‘Artangels’ streamed from Qobuz
    d. ‘Artangels’ from local storage on nucleus
    • Every track stopped as I described in my original post.
  3. Here’s the interesting part… I then switched my Atom from 5GHz to 2GHz.
    • Every track in my 4 track Troubleshooting playlist played without any issues.
  4. Switched my Atom back to 5GHz. Repeated step 2. with the same result of every track failing.
  5. Repeated step 3. on 2GHz. Every track once again played without any issues.

This is really starting to look like I either have a 5GHz issue with my ASUS router or a 5GHz issue on the Atom itself. Since I was able to play my test tracks to my computer yesterday (see previous post) and I was on 5GHz while doing that, I am leaning toward the 5GHz issue being on the Atom. I’ll reach out to Naim and see what they say.

@Techru Thanks for suggesting using a wired connection. You got me to think down a different path I was mostly ignoring until you mentioned it.

@jamie Unless you have other thoughts, I don’t think this is a Roon issue. Thanks for jumping in and suggesting using different endpoints to test.

1 Like

Thank you for sharing your discoveries @gsuzor91! Excellent detective work there. If the 2.4 gHz channel is working well I’d continue to use that until you get some advice from Naim.

You may also want to check for new Firmware for the router, however based on your testing, you’ve probably already explored that possibility. Perhaps also check to see if IPv6 has independent settings per router channel and de-activate it if it is turned on.

If you haven’t already done so, your router has Quality of Service (QoS) settings, which will let you prioritize network traffic So, you should be able to select the Naim IP and prioritize signal to that device over other devices that are also using the 5 GHz channel.

Once prioritized, you could then retry your tests and see if the issue is resolved. If it is, that basically means that you have another 5 GHz device that is “interfering” or stealing bandwidth from your Atom.

1 Like

That’s a great suggestion @Techru. On some router apps all devices are set to priority by default. Reconfiguring the priority traffic to only devices that really need it can improve your network overall.

@Techru and @jamie I’ve used QoS in the past, but had it turned off. I enabled it again and manually set the Nucleus+ and Atom to highest priority. They were the only devices at this priority. However, this did not help.

At the moment, the Atom is on 5GHz all by itself. I have minimal other devices connected, and my closest neighbor is 200+ feet away. Nothing else is streaming while I’m testing. I’m on 300 Mbps cable and I can see the songs download quickly via the traffic monitor on the router, then stream steadily at a low rate to the Atom. So essentially, I really shouldn’t have any bottlenecks or too much interference.

I also upgraded my router firmware a few days ago. So @jamie you were correct… I had already upgraded it. :slightly_smiling_face: I try to keep it up-to-date but was two or three versions behind. Unfortunately that didn’t help.

I’ve also been playing with a bunch of other router settings including the control channel, channel bandwidth, tx bursting, etc. With the repeated testing I’ve done, one thing is clear to me - the tracks I have in my troubleshooting playlist fail 100% of the time when the Atom is on 5GHz (*1). It’s not random. Other tracks normally play fine. I even have a 45 minute 352.8kHz 24 bit track that plays end to end without issues.

(1 - So that’s not quite true. I now know my troubleshooting playlist fails 100% of the time when my Atom is on 5GHz 802.11 ac and a certain other router setting is set. Summary of that to follow in my next post.)

5GHz 802.11ac Issue

  • 5GHz Wireless Mode = N/AC mixed
  • NAT Acceleration = Disable
  • Atom 5GHz 802.11ac

My four track troubleshooting playlist fails 100% of the time when my Atom is connected on 5GHz 802.11ac and my RT-AC68U router has NAT Acceleration disabled. The router is therefore doing extra processing on its CPU, and is likely the cause of the issue.

Workaround 1

  • 5GHz Wireless Mode = N/AC mixed
  • NAT Acceleration = Auto [Cut Through Forwarding]
  • Atom 5GHz 802.11ac

If I set NAT Acceleration to Auto and have all extra features that may use the CPU disabled, then the router will use what it calls Cut Through Forwarding (CTF). With CTF in use bypassing the CPU, then every song in my troubleshooting playlist plays all the way through.

Workaround 2

  • 5GHz Wireless Mode = Legacy
  • NAT Acceleration = Disable
  • Atom 5GHZ 802.11a

I have not done extensive testing with this configuration, but so far my troubleshooting playlist plays all the way through. It seems the router CPU doesn’t get in the way here.

So, I purchased a new ASUS RT-AX88U router. :upside_down_face:

What I found per my previous post convinced me my RT-AC68U was at fault. It either couldn’t keep up or has faulty hardware, even though in daily usage for home and work tasks I thought it was rock solid. I purchased it in 2014, so decided it was time for an upgrade.

The RT-AX88U has different settings, so I can’t replicate the exact setup where my AC68U was failing. I’ve only had the new router for a few days, but so far so good. It will play all the tracks in my troubleshooting playlist.

@jamie Thought you might be interested in this next part, just from the peculiarity of it. There is one remaining aspect that I can’t explain (though I do have some guesses) after I did additional testing. If the RT-AC68U has faulty hardware and it failed as consistently as it did for the Atom, I would sort of expect it to fail in a similar way when streamed to my desktop. However, my troubleshooting playlist tracks would always play to my desktop. I even manually played the troubleshooting playlist to my Desktop and Atom at the same time while both were on 5GHz 802.11ac. They were not grouped / synced. In this scenario the tracks played all the way through on my desktop, and each track to the Atom would stop. It seems the RT-AC68U is delicately putting the packets on an edge case that affects the Atom, but not my desktop. :thinking: