Frequent Core Restarts/Lost connections after 1.8 build 884

Roon Core Machine

Roon Core - Nuc i7 8G Ram 128GB SSD running Roon Rock 1.8 Build 884 ethernet
Roon Database & settings use 70% of storage available

Networking Gear & Setup Details

Remotes - Mac Pro Mac OS 11.6 ethernet
iPad ipadOS 15.2

Connected Audio Devices

USB on Mac Pro
PS Audio network Bridge II

Description of Issue

After upgrade to build 882 I could not get a backup. Core would restart during a backup Manual or Automatic. I thought that it may be caused by a corrupt database as I have seen in the forum.

I did a full rebuild from scratch. After rebuild I did get a backup. But today I cannot backup the system. The core restarts frequently.

Not sure if I should restore from last backup on 884 as that DB somehow got corrupted going forword OR Roon’s staff need to do a scan of my logs to see if I have another issue.

I am at a lose as to how to proceed.


Make a backup of your last back. Sounds goofy but I have trust issues.

Then I’d go up to 884 and restore from a copy of the latest backup. You have nothing to lose. A number of people report their issue were handled.

Good luck with it.

I will give that a try.

I can not find any guidance on what could be causing the backup to fail. If it is corruption I thought I might get a message. If it is a failing SSD then How do I determine if it needs replacement?

I would think if Roon is not going to provide reasonable service support that they provide more extensive documentation or tools via the web-gui, especially since the Rock is a stripped down propitiatory linux version usually operating in a headless manner.


Did a complete reboot of the NUC.

Tried to restore from the backup but Roon (Build 844) restarted/Lost connection in a few seconds of the restore starting. So currently unable unable to restore.

I can play music but it may restart at any time.

I plan to do another complete rebuild Tomorrow unless I hear from a Roon support person that I am not doing the right thing.


Hey @Joseph_Cira, I had a look at your logs and noticed this:

12/27 21:14:02 Warn: [storage] [directory] Cannot iterate dir: '/roon/sys/storage/mounts/ROON10c_WD_My_Book_25EE_4A454B343848384E_0693-BB72-p1/HD Library 3/Various Artists/Christmas Choirs (2020)', ex: System.IO.PathTooLongException: The path '/roon/sys/storage/mounts/ROON10c_WD_My_Book_25EE_4A454B343848384E_0693-BB72-p1/HD Library 3/Various Artists/Christmas Choirs (2020)' is too long, or a component of the specified path is too long.

Can you try shortening the name of your storage folder?


The Drive NAme is “ROON10c”
The Sub- Folder is “HD Library 3”
The “_WD_My_Book_25EE_4A454B343848384E_0693-BB72-p1” seems to have been added by Rock(Linux) or the Core App. I would love to shorten it.

Can I just rename it in the Data/Storage folder?

These names have been unchanged since I install the NUC 3 years ago and I have never had an issue accessing the tracks.

The Metadata for the Albums / Tracks are all done using “ID3v2.4(UTF-8)” meta tag standards which you support.


I believe this was under 882. I have since rebuilt the data base from scratch under 884. The first auto backup worked but not since. I get a restart when I do a backup. I tried to restore from the one backup I had but it failed.

I am prepared to do a new rebuild from scratch if that is the issue.

If you require new logs let me know.


The problem seems to getting more sever.

If I scroll through the Album list of covers I can cause a restart.

I need major help.


Thanks for the extra info @Joseph_Cira, let’s have you try this:

  1. Stop Roon Server from the ROCK web administration interface
  2. On your Mac Pro, open Finder and navigate to smb://ROCK/Data and use Guest as the username and password
  3. Open the RoonServer folder
  4. Delete the Cache folder
  5. Restart Roon Server

If you continue to get random restarts, let me know the local time & date that it happens and I’ll have a look.

1 Like


I deleted the Cache folder as you asked.

The issue with the restarts during scrolling seems to be solved. I play a number of tracks with no issue.

However, when I attempted a manual backup it restarted with no message. (7:41pm EST)

When it came back up it restarted again for no apparent reason when I attempted to select an Album. (7:44 pm EST) The was follower by a third about 2 minutes later.

My schedule backup is a 7:00 am EST everyday.


1 Like

Hi @Joseph_Cira,

I took a second look at your logs–it appears that your Roon Core is running out of RAM because you have an extremely large music library, in the top 1% or so of all of our users.

Any chance you can upgrade it to 16GB RAM? It will be a lot more stable, and probably perform better too.

I can do that for sure. I will order some tonight.

Do you have a recommendation for a 16GB simm or a second 8GB simm?


Is this the cause of my failures? Do I have other issues?
I do not want to thrash about doing things that will not address the root cause.

Hi there,
I am experiencing the same issues.Since December 17th have regular core restarts. It is really annoying. Roon is running on a Nucleus and the music is stored on a build-in SSD.
Connected devices: dCS Bartok and Project Streambox S2 Ultra.

Update>as a learning from this thread I have emptied the cache. I’ll keep you posted on the result.

I have also been having a lot of restarts since the most recent updates. I can reliably cause the ROCK to restart by scrolling quickly on any of my remotes: MacOS, iOS, and iPadOS. Also, changing the view to suddenly display a new set of albums seems to cause the same behavior. This is all especially the case when I use a large monitor that displays a large number of covers at the same time. I am currently deleting the cache on the server (ROCK) and will post my results.

One additional note: I also have a rather large local library.

I deleted the cache and resorted the core and remotes. At first the situation seemed solved, i.e., it survived a couple of quick scrolls and the album covers filled in (from the grey placeholders). After 6-7 times the core crashed as it used to. It might be good enough for normal usage (instead of stress testing). I will post my results with regular usage.

How much RAM do you have and what is your library size?

Let me preface my answer with an acknowledgement of the fact that I have a problem and have had one for over 30 years now. Also, everything was working beautifully before the latest update.

my library has 328,522 tracks across 22,383 albums.

I know here is no way to ssh to get the RAM installed, is the another way to check without physically opening up the server?

It is possible that prior to the update you were running very close to the edge and now with some of the changes in the latest build it has pushed your RAM over the edge so to speak.

I don’t know if there is a way to tell your RAM apart from opening it up and looking at it physically.

If someone does then if they could chime in?

Yes, if you want to add additional RAM then you should open the NUC and look what RAM is installed. If there is just one stick, then you want to get as close the same make/model of RAM. If there are two stick already installed, then (since most NUCs only have two memory slots), you would remove them both and install a brand new stick or pair. (personally I usually install a pair at a time).

So, if you have 1 8 gb module installed, then you want to get another 8 gb module of the same manufacturer and model. If you have 2 4gb memory modules, then you will need to remove them both and purchase a 16 gb module (single or a pair of 8 gb) that best matches with the NUC motherboard.

If you want some help with that, feel free to PM with the NUC model number and the RAM make/model number.

I am actually shocked I’ve made it this far since I only have 8gb installed. Is there any value in maxing out the RAM or at least taking it to 32gb (if I can) or do you think 16 will be enough?

TheHammer your explanations seems to be the most plausible I have heard yet. I hope you are correct. The issues all start with the 880/882/884 builds. No issues previously.

I have ordered an additional 8GB simm to double my RAM to 16GB. Should have it installed tomorrow.

Let you know the outcome.


1 Like

You are also having out-of-memory issues. Based on your system’s diagnostics, I think 16GB should be enough.