Frequent track skipping and long pause before playing tracks

Core Machine (Operating system/System info/Roon build number)

ROCK - Version 1.7 (build 571) on a NUC (model NUC8i3BEH), 256GB M.2 SSD, 8GB RAM, 2TB WD Blue for local files.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Gigabit ethernet, fast fibre broadband (150Mbps), ZTE router (provided by my fibre supplier), Netgear ProSafe switch, Cat 5e cable. Most network devices are wired (incl. the NUC/ROCK).

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Various speaker/endpoints, incl. 2 x Sonos One (Airplay) & B&W Zeppelin Air (wired). I live in a reasonably compact inner-city flat with a strong WiFi signal.

Description Of Issue

If I play an album the first track is frequently skipped. Other tracks are occasionally skipped. This applies particularly to local files (most of my library is local) and seems to affect newly ripped/added albums more - though it does affect Qobuz albums too now & again.

There are also frequent long pauses between tracks (usually about a minute) - again more often with local files.

I have a medium sized library - about 2,400 albums - of which 1,600 are local and the rest are on Qobuz.

I’ve been using Roon for 2 or 3 years and this issue has been particularly noticeable in the last month or two. It’s very irritating - I often have to clear the Play Queue and re-cue an album - often several times.

Everything was fine before that. I’ve tried to figure out what might have changed in the last couple of months - but nothing has that I can think of.

Any ideas what might be causing this - and how to stop it?

Thanks.

1 Like

Is the NUC very warm? Perhaps the fans are clogged and the unit is suffering some thermal throttling?

Hi. Thanks for the suggestion - but no - the NUC is cool to touch.

what about showing some screen shops of the Signal path when these occur. Processing speed issues? And DSP options enabled?

Nothing out of the ordinary. Here’s a signal path grab while it skips a track:

sp

… and no DSP options enabled.

Managed switches have caused various issues, is it a managed or unmanaged prosafe?

It’s managed. There are no issues with the switch - it has run flawlessly and without issue for 3 or 4 years. The skipping and pausing has only been happening in the last month or two.

I generally know what I’m doing re. network and hardware - I was a unix sysadmin in a previous life.

Well as you’ve probably gathered the symptoms, in roon land, sound like a network problem somewhere.

Hi @Simon_Finch,

Does the issue impact all of your zones or just the Sonos zone?

What is the amount of tracks in your library?

I have seen switches fail in the past, so I wouldn’t outright exclude this possibility. If you can try to connect your Core + one endpoint to the main router as a test, that could yield some good info.

Hi Noris

Thanks for your reply.

Total tracks (incl. Qobuz) = 44,550.

I’ve seen switches fail too - but if this one were to fail I would know about it very quickly. (I run a couple of file servers and various other services locally.)

The weak link does seem to be the Sonos Ones on Airplay. I will switch them to ethernet/wired and monitor the situation for a couple of days.

1 Like

Does this happen with Qobuz as well as your own files? If with your own music files then this might be of interest… I started seeing this awhile back and ultimately chalked it up to bad network karma. But eventually I noticed a problem with the hard drive where the music was stored. I ran a chkdsk (using Win 10) and sure enough it found some problems although it was able to correct them. After that, the track skipping dropped significantly (but I can’t say it has completely stopped).

Could it be that the hard drive storing your music is having issues or perhaps spinning down and taking a long time to spin back up? Not quite sure how Roon handles these issues.

@Simon_Finch -

If it’s just the Sonos One mostly impacted by this, I would agree with trying Ethernet on them, perhaps the WiFi channels are a bit congested in your area.

1 Like

Any update to this @Simon_Finch?

Joe

Hi Joseph

Sorry I didn’t update this – yes, it’s pretty much gone. Switching the Sonos Ones to ethernet did it.

Thanks,

Simon

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.