Fresh install, roon client from downloads, catalina -> Fatal error - could not create required lock file

I’ve searched the forum and tried the previous methods to resolve this problem without success,

Is there a revised method to resolve this issue on catalina please?


Hello @mannp,

The “Could not create required lock file” error is usually caused by running two instances of the Roon application at the same time. I would recommend rebooting the computer to ensure that you’ve wipped out any potential rogue Roon processes before trying to launch Roon again.


Hi @john thanks for the prompt reply.

Mmh thats odd as I have rebooted a couple of times and I still get the error.

Is there a file lock.file that I can delete as roon is not running, so the file must have gotten left behind somehow?

Hello @mannp,

Before continuing with the next troubleshooting step, ensure that you have closed any instances of Roon (if you’ve been able to get them started).

A) Open Finder
B) In the Menubar, go to Go > Go to Folder
C) Type in /tmp/
D) If you do not have hidden files visible, use the keyboard shortcut “cmd + shift + .” to enable visibility.
E) Delete any files starting with the .rnsem prefix.
F) Try to start Roon.


Hi @john

So running roon from the command line doesn’t give anything away;

10:02:46   /Applications/
Initializing Broo Bindings
Remoting Api Initialized
00:00:00.000 Debug: Attempting to load library: /System/Library/Frameworks/Foundation.framework/Foundation
00:00:00.007 Info: Library[/System/Library/Frameworks/Foundation.framework/Foundation] Loaded success => True
00:00:00.007 Debug: Attempting to load library: /System/Library/Frameworks/AppKit.framework/AppKit
00:00:00.007 Info: Library[/System/Library/Frameworks/AppKit.framework/AppKit] Loaded success => True
00:00:00.866 Debug: Attempting to load framework: /System/Library/Frameworks/Cocoa.framework
00:00:00.871 Info: Framework[/System/Library/Frameworks/Cocoa.framework] Loaded success => True
00:00:00.872 Debug: Attempting to load framework: /System/Library/Frameworks/OpenGL.framework
00:00:00.875 Info: Framework[/System/Library/Frameworks/OpenGL.framework] Loaded success => True
00:00:00.875 Debug: Attempting to load library: libHIDRemoteNative.dylib
00:00:00.893 Info: Library[libHIDRemoteNative.dylib] Loaded success => True
00:00:00.893 Debug: Attempting to load library: libSPMediaKeyTapNative.dylib
00:00:00.909 Info: Library[libSPMediaKeyTapNative.dylib] Loaded success => True

There are also no .rnsem files, in the /tmp/ directory.

I also tried -v for more verbosity on the roon start but it appeared to be ignored.

Hello @mannp,

Try disabling the “Accessibility” permission for in the System Preferences > Security & Privacy controls.


Hi @john sadly that did not help.

Everything else seems to work fine, except roon, so I could do without a reinstall.

Hello @mannp,

Let’s check if your permissions for the /tmp directory are set correctly.

Try the following commands in the macOS terminal:

cd /tmp
echo hello > test
cat test

If the permissions are set correctly, you should see hello print below the cat test line once you have executed the command.


Cool thanks @john your test failed with permission denied, so I ran sudo chown $(whoami) /tmp and Roon started :slight_smile:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.