Fresh install throws "ERR_CONNECTION_REFUSED" when applying settings. AirPlay does not show up

Roon Core Machine

Raspberry Pi 3 B V1.2

Networking Gear & Setup Details

Ethernet

Connected Audio Devices

Qudelix 5K via USB

Number of Tracks in Library

N/A

Description of Issue

Just setup a fresh of RoPieeeXL 2023.1 (0711) and whenever I change settings and click Apply I get the screen below and have to wait for RoPiee to reboot, I think? Not entirely sure what it’s doing but I can’t access it for 10-15 seconds afterwards and the settings aren’t usually saved.

Screen Shot 2023-01-25 at 7.00.40 PM

I did somehow manage to get the AirPlay settings to save (they don’t always) and RoPieee seems stable if I’m not applying settings but it does not show up as an AirPlay device on my network. Yes my
phone and macbook are on the same LAN and there’s no special networking between them etc.

Was going to try Spotify Connect but can’t get it to save my login.


I tried a previous version (ropieeexl_ose_pi3-2022.11.2-stable.20221206.662) and that resolved the Apply issue and I got AirPlay working.

However, it plays very choppy regardless if I use my Macbook or Phone as the AirPlay source. As per above I have the Pi wired with Ethernet.

I also tried:

  • Switching the Pi to WiFi
  • Different USB ports on the Pi
  • Different USB-A to USB-C cables for the Qudelix (even though the stock cables works with my Macbook and the Qudelix)
  • Upgrading to the latest version from the previous version after AirPlay settings were set

Still stutters…

Yes this is an unfortunate regression that came with the new API.
I’ll release a patch this weekend to fix this.

Awesome, thanks!

Any ideas on what might be causing the audio to cut in/out when using AirPlay? I haven’t been able to try other streaming methods so not sure if it’s specific to AirPlay or all methods.

It might be something to do with the Qudelix 5K. I just received a Fiio LT-LT1 Lighting to USB-C cable today to run it with my phone and it has a similar symptom where it seems to constantly disconnect and reconnect in a loop. This seems like it could be the same behaviour that’s causing the audio to cut in/out when connecting it to the RoPieee too, but not sure. It’s weird because it works fine when connected to my Macbook and Gaming PC. Could it be a power draw thing because the 5K is trying to charge? I’m attempted to disable the power draw in the 5K settings but there might be a bug preventing it from disabling, TBD.

When I connect a cheap SoundBlaster Play 3 USB DAC to the RoPieee it works fine so I know it’s not entirely an issue with the Pi or RoPieee, maybe a combination of it and the Qudelix at worst. hmmm