Frustrating problems with Mytek Brooklyn Bridge and Tidal

Core Machine (Operating system/System info/Roon build number)

NUC6i3SYK with 64gig SSD, 4GB RAM, ROCK with Server V1.7 (build 537) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Google Nest Wifi
TP-Link TL-SG105 Unmanaged Switch
TP-Link AV600 Powerline Ethernet Adapter

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Mytek Brooklyn Bridge connected through Ethernet
Used for Tidal only, no local stored music

Description Of Issue

Been nonstop problems streaming Tidal through the Brooklyn Bridge. Most of the time the Brooklyn Bridge won’t show up in my Audio Zones and when it does it plays the first few seconds of a track before skipping or dropping off completely. Roon gives me an error message “Tidal media is loading slowly. This may indicate a network or connectivity problem.”

After scanning the message boards here I’ve tried these solutions to no avail:

  • Restarting, reinstalling Roon Server
  • Emptying Roon Cache
  • Using Static IP with Google DNS
  • Removing the network switch and powerline from the process
  • Using Mytek’s WiFi instead of ethernet

Nothing has worked. It’s incredibly frustrating after investing a lot of cash into this setup. Would love your help.

Thank you!

Hi @Spencer_Somers,

Welcome to the forum and thanks for reaching out, we can certainly take a look over these issues. Let’s start troubleshooting with the following:

  1. What is your internet download/upload speed according to

  2. Do other zones work as expected? If you try outputting to the ROCK’s HDMI zone or to a Roon Remote’s (Android/iOS) internal speakers, do you have TIDAL playback issues there?

  3. Are you using the latest firmware on the Mytek?

  4. Does this issue only occur on certain types of TIDAL content, such as it only occurs when trying to play back MQA or content over 44.1kHz?

  1. 205mps DL, 23mps UL
  2. Yes, all other endpoints work. Tested with ONKYO AVR and MacBook Air as remote.
  3. Yes, I have installed the latest firmware on the BB
  4. It occurs with all content, just tested MQA and 44.1kHz to be sure

Hi @Spencer_Somers,

Thanks for confirming. Can I please ask that you reproduce this issue on the Brooklyn Bridge and note the exact local time + date + track the issue next occurs on? Once I have this info I can enable diagnostics mode for your Core to see if we can get more clues in the logs.

For the first few hours of streaming today it worked perfectly. Was able to listen to 3 Miles Davis Albums without hiccups. Then at 7:12 PM PST on May 18, I tried to listen to the album Discoveryby Daft Punk and every track skipped after 6 secs or less

1 Like

Hello @Spencer_Somers,

Thanks for letting me know that timestamp. I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

I can confirm that this report has been received and I have requested additional feedback from the technical team regarding your case, once I hear back from them with further information, we will reach out once more, thanks!

Hello @Spencer_Somers,

We apologize for the delay in getting back to you, the diagnostic logs showed some odd behavior and the support team wanted to clear things by the QA team before responding.

It appears that the issue during streaming is occurring on the Brooklyn Bridge network module, your Roon Core appears to be operating normally.

What we see in the logs is that the Brooklyn Bridge is reporting “Dropout” traces which means that it is unable to fill the audio buffer with data fast enough to keep up with playback:

Trace: [Living Room] [Lossless, 16/44 TIDAL FLAC => 16/44] [100% buf] [PLAYING @ 0:44/3:46] Harder, Better, Faster, Stronger - Daft Punk
Warn: [Living Room] [zoneplayer/raat] long rtt sync Mytek Brooklyn Bridge: realtime=14519782977070 rtt=364500us offset=-388025022us delta=43687us drift=349721us in 882.1595s (396.438ppm, 1427.176ms/hr)
Warn: [Living Room] [zoneplayer/raat] long rtt sync Mytek Brooklyn Bridge: realtime=14521944518345 rtt=418000us offset=-387950481us delta=74541us drift=424262us in 884.1855s (479.834ppm, 1727.404ms/hr)
Info: [stats] 21982mb Virtual, 669mb Physical, 274mb Managed, 283 Handles, 77 Threads
Trace: [Living Room] [Lossless, 16/44 TIDAL FLAC => 16/44] [100% buf] [PLAYING @ 0:50/3:46] Harder, Better, Faster, Stronger - Daft Punk
Warn: [Living Room] [zoneplayer/raat] long rtt sync Mytek Brooklyn Bridge: realtime=14523940144089 rtt=435500us offset=-387940855us delta=9625us drift=433888us in 886.1615s (489.627ppm, 1762.657ms/hr)
Trace: [Mytek Digital Brooklyn Bridge @] [raatclient] GOT [13648] {"samples":11958,"status":"Dropout"}
Trace: [Mytek Digital Brooklyn Bridge @] [raatclient] GOT [13648] {"samples":24696,"status":"Dropout"}

I recommend reaching out to the Mytek support team with this information and continuing troubleshooting with them. I would be interested to see if you’re able to stream without issue using the MConnect application on a smartphone. Based on the troubleshooting you’ve already performed, I would think that the network is not the issue here.


Thanks John and team for following this to the end and giving me confirmation that it’s not my network. I’ve taken the issue up with Mytek and have sent the Brooklyn Bridge in for repair. I’ve cancelled my Roon account as to not incur charges until I know I have a network bridge that works. Hope to come back to Roon when it does.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.