Full MQA encoding on Klipsch Heritage headphone Amp. via Roon (using MacBook Pro as Core)

Core Machine (Operating system/System info/Roon build number)

MacBook Pro 13" Mid 2015, Roon 1.7 (build 667)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wifi using TPLINK Router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

USB Cable to Klipsch Heritage headphone amplifier, Sennheiser HD800S headphones

Description Of Issue

I can’t get the “Purple Indicator” showing Full MQA playback. I also use the Tidal and there is a feature which allows me for Tidal to take full control of the Klipsch device making sure I’ve got full MQA (I can tell as the device as an LED Khz indicator which changes according to the sampling rate of the song being played). I find it all very complicated as I can’t activate the Klipsch Device in Audio when I enable it. Looks like the device is not supported but it has a full DAC facility.

How do you have it set up in roon?

That dac/amp doesn’t appear to have mqa capability. If so you would only get the first “unfold” and that is done in the player. In roon, you would specify “master” quality for your tidal account setting, and in audio settings specify “no mqa” for the dac on turn on roon mqa decoding. I think this is how it would work.

yes it seems that way. In Tidal I can set it to “Exclusive Mode” so that Tidal controls the DAC/Amp. Does Roon have this feature?

You need a MQA support on the DAC hardware to have full MQA unfolding. Your Klipsch DAC does not have MQA support.


I’ll attach the screen shots if the settings…


Yes I see that now. I’m fine with that… Sent my setup in previous reply… I’m happy with the sound. Any recommended changes?

Yes. See audio settings for the dac/amp…

You don’t have the dac/amp enabled. You’ll get better sound if you enable it and go through the settings for it and select it as your output device.

Working… thanks so much for your assistance…


Hello @Tony_van_den_Bout, glad to see you got some help here! Please let me know if you have any further questions.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.