Genre Missing In Action

Content you’re reporting an issue with

When viewing Genres, the listing does not include Opera, for which I have a few hundred recordings.

Have you made any edits to this content in Roon?


Is this content from local files, TIDAL, or Qobuz?

Local files

Screenshot of import settings

Cannot supply a screen shot, as the genre is missing!

Description of the issue

I’ve looked at related threads, but haven’t found one that directly addresses my issue. Apologies if I am duplicating a prior thread.

I have a few hundred opera recordings (all on a Synology NAS, served from a Nucleus). Some have a special tag (I used Yate to create tags), for example ‘Callas Remastered’, which shows up as its own Genre. So far, so good. But most of the recordings are tagged simply as ‘Opera’ – which is a Roon genre – and yet no Genre ‘Opera’ shows up. I’ve tried adding a tag to some of these recordings, to see if Roon will find them, but they are still missing from the Genre listing. If I look under Albums (I list by Composer: title of album), they are all there, and playable – so Roon sees them, but not within a Genre. Finally, I have the imported file genres to File, not Roon; but just for completeness, I also ticked the ‘Roon’ box – the recordings are still MIA.

Any idea of how I might trouble-shoot and fix this?

So do you want to say that when you open the genre browser in Roon, click on the classical genre, scroll all the way down to the place where the subgenres are listed, you can’t find opera there?

Hi BlackJack,

Thanks for the fast response. If I choose ‘More’ when I open the Classical genre, I see all the classical albums, but none are Opera, and there is no subgenre in that view. If I don’t choose ‘More’, then I see the Opera subgenre below and Roon lists my opera recordings. This seems too complicated, since the Genre mapping shows “Opera” maps to “Opera”; and yet there isn’t a Genre of “Opera.”

Then again, if Roon sees Opera ONLY as a subgenre, then at least I know how to get to it. I never saw the subgenre because I was always choosing “More” in a Genre, to see all the listed albums.

@BlackJack has already ‘solved’ your initial question, but there’s one other thing you can do that might make your browsing experience a bit easier. By default, Opera is a sub-genre of Classical, but you can edit it to make it a top level genre in it’s own right. If you’d like to do this, click the three dots next to the Play Now button and then select ‘Edit …’

Then click ‘Edit’ and then ‘Choose genre’.

The last step is to click the ‘Make top-level genre’ button. Once you’ve done that Opera will be classed as a genre rather than sub-genre.

1 Like

So helpful! I couldn’t figure out how ‘Vocal Recital’ was top level, but Opera was a subgenre. Knowing that these are all editable is great – and a great feature. Thanks to you both.

1 Like