Germany: M-Net + Fritzbox - Port forwarding issue [Solved - Request Static IPv4 Address from M-Net]

Philipp, I also have M-Net + Fritzbox, with their IP4-Option, ARC works. Without this option, M-Net only provides an IPv6 address. Good luck.

2 Likes

Thank you - that’s great to hear. I‘ll report back once the option is active.

Hi mikeb,
it seems like the IP4-Option is now active, but ARC still does not work. This is the error message:

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“212.114.229.193”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

Did you change any settings in your Fritzbox? Did you assign a fixed IP to your core? Any other hint/tip how I could get ARC working? Thanks a lot!

Hi Philipp,

i´m not at M-Net but have a FritzBox too and got ARC Port running with a IP change at my provider.
your protocoll looks like you have upnp auto port forwarding off. i would try first to activate this again.
manually works too for me but automatik works good in FritzBox router

Is your IP with “whatismyip” sites now the same as in the protocoll?
I use DHCP in the Fritzbox but my Rock Core uses always the same IP in my network.

1 Like

a good simple site to see your IP and check for open port is this

1 Like

Hi Tom,
thanks a lot for diving into this.

There is this Fritzbox option “Transmit status information over UPnP” which was active. But I read that sometimes deactivating, applying and then activating again helps. So I did it. Now the error message looks different - better even :wink: - but still ARC won’t be able to connect to the core.

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“212.114.229.160”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.178.1”,“found_upnp”:true}
}

Regading the IP - this is the external view on my network:

image

The port is still closed from the outside (thanks for the link!). I’m wondering if my ISP really activated that IP4-option… I’ll try to reach someone there. Thanks again!

1 Like

I think they did, as you have an ipv4 address. You can confirm this in your FRITZ!Box > internet > status. Or on the home page. When I get home I can send you a screenshot of the port forward rule, but I think someone else posted it here too.

2 Likes

Hmmm… I don’t see an IP4 address in the Fritzbox…

1 Like

could be this “DSL Lite tunnel” at IPv4 is your problem, maybe you should talk to M-Net again for a “static IP” or “öffentliche IP”

55000 is open in FritzBox as the screenshot says, so it will be a problem at M-Net i think

1 Like

Ok, so that’s bad, you should see both an IPv4 and IPv6 address there - ARC needs that IPv4 address. The DS lite tunnel is without the extra IPv4 option I believe. I’ll share screenshots when I’m home!

2 Likes

Thank you both for your help. Very much appreciated!
I’ll call M-net now…

1 Like

You may just need to power cycle your FRITZ!Box, if mnet say they’ve enabled IPv4

1 Like

Good point. Did this in the morning though…
Let’s see what M-net says. I want the confirmation that the IP4-Option is active.

That you are on M-net, have a Fritzbox too, and ARC is working at your side still leaves me optimistic :slight_smile:

from M-Net site:
“M-net verwendet hier das standardisierte und erprobte Dual-Stack Lite Verfahren, das neben IPv6 auch IPv4-Konnektivität für das interne Netz des Kunden gewährleistet. Damit können Kunden die in ihrem Heimnetzwerk vorhandenen Geräte und Anwendungen, die das IPv6 Protokoll noch nicht unterstützen, weiter verwenden. Dies gilt ausschließlich für das interne Netzwerk und nicht für den Zugriff von außen auf die internen Resourcen.”

i am no network pro, but it looks like your connection is over IPv6 with a IPv4 Tunnel for IPv4.
M-Net will know better :wink:

good luck Philipp :slight_smile:

1 Like

Just for the record, here are my contract details:

1 Like

Fritzbox screenshots sent by PM.

1 Like

I also have a Fritzbox and I am based in Germany. Initially the automated setup didnt work until I enabled “Selbstständige Portfreigaben für dieses Gerät erlauben”. Since then it is working :star_struck:
Good look with your setup

3 Likes

All solved. The IP4-Option of my ISP (M-net) was finally activated today - and voila - it works.
Thanks all for the support here! Great to be part of this community.
Looking very much forward to use and test ARC! Let the games begin :slight_smile:

5 Likes

nice to hear that, have fun trying it out :slight_smile:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.