Getting different search results (amount of content displayed) between remotes - iPad and Android tablet

Problem that I thought was solved, is recurring;
Searches with apostrophe (e.g., “The Soldier’sTale”) or dash in the search only turn up only partial results.

Hi @danny2 ----- Thank you for the report and sharing this observation with us, the insight is appreciated.

Moving forward, would kindly please provide the following information:

  1. A very brief description of your current setup, so I have a better understanding of what you’re working with.

  2. Are you noticing this behavior on all of your devices (core and remotes)?

  3. Can you provide a screenshot highlighting this error behavior? I just did a quick Roon search using: “The Soldier’sTale” & The Solider’s Tale and I am seeing the same search results for each on my android remote.


Eric -

Thanks. Since I wrote I’m getting different behavior. Some local search works, but is incomplete. Example:
Since I have multiple versions of every Beatles album, I made one group of my preferred version of each album which is my default version for listening. I named the artist: “The Beatles - Danny’s Reference” to differentiate from other versions.

As you can see in the screenshots, I get more results from the iPad search than from the Android tablet search.
15 albums vs 9. (The ipad actually gave me 16, but one was on the next screen).
I’m not posting, but my Windows10 Laptop PC gave the same (correct) results as the iPad. My Android phone (Android 7) gave incomplete results,same as the tablet. (I think the Tablet is Android 4). I have the latest versions of Roon on all my devices. The server is Windows10 with RoonServer.

Hi @danny2 ----- Thanks for the follow up and the feedback.

Touching base to let you know that our QA team is going to look into this behavior you’ve reported and once I have some feedback I will be sure to update this thread asap. Your patience is greatly appreciated!


Noting that I did a search for the group “King Crimson”. Not getting integrated results with my server based library and Tidal albums I’ve added to my library. Each is in its own window of results.

Hi @danny2 ----- Thank you for your patience and my apologies for the wait here. We’ve been discussing this thread internally to figure out what the next steps should be here. Your patience has been appreciated.

Moving forward, can you verify the following for me:

  1. When you notice this behavior, are you using the same profile every time?

  2. Is your core machine changing at any point or are using the same one each time?

  3. What is the experience like if you try without “dashes” and “apostrophes”?


Hi Eric-

  1. yes, same profile

  2. no, I have only one core machine running RoonServer headless, Windows10 Pro 64bit

  3. without dashes and apostrpophes, I get:

same results as before with roon app on windows 10 and ipad-full results, 16 albums.
same results as before on android tablet (android 5) and phone (android 7) - not full results, only 9 results as opposed to 16 on ipad and on Windows.

Hi @danny2 ----- Thank you for touching base with me and providing the requested feedback, very appreciated!

Moving forward, I would like to grab some remote logs from the devices that you are experiencing this behavior with and will be contacting you momentarily via PM with instructions.


Tried to follow the instructions, but keep getting the error, “couldn’t connect to our server”. Mutiple tries from both devices. My internet connection is working fine, so it isnt that.
I will try again tonight or tomorrow.

Hi @danny2 ----- Thanks for the follow up and sorry to hear of the troubles. I just tested on my end and was able to send a support package with one of my Roon remotes, successfully.

Please let me know how it goes the second time around.