Getting HQPlayer to Output to DAC

Local source doesn’t work for me. I have to use the IP number of the computer.

Remember after Roon hands off the audio to HQPlayer. HQPLAYER is then responsible for sending the audio to the Endpoint, not Roon.

Good point, something to try

That is the point of my suggestion above, to check HQPlayer is actually working properly with DAC:

Then, just load HQPlayer and try and play music from it to the DAC. When you can, then, add Roon in.

1 Like

Yes that’s exactly what I wrote :grinning:

1 Like

Still working on it, have to quit for the moment, probably until tomorrow morning. Thanks again for your help!

1 Like

Attempting to play a file using HQ Desktop and HQ Client, Roon not turned on. Set Client alternately to localhost and IP4 address. Tried to drag both folder containing flac files and individual flac files to HQD library section or all over the place. As I drag, the ghost image of the album cover says +copy, but nothing lands.
Will continue trying to get Roon + HQD to work.

For this quick test, no need to use HQP Client.

Just drag one FLAC file into this window of HQP Desktop. And press play.

Did that. Dragged flac file into that area, it showed +copy, I let go, nothing went there. Pressed PLAY and, of course, nothing happened.

2 adds to last reply:

  1. (talking about running HQPlayer without Roon) I can get music folders into HQPlayer Library, but that won’t play.
  2. (talking about running HQPlayer with Roon) Roon doesn’t seem to notice whether or not I have HQPlayer Desktop app opened or not. Just gives same message that Roon cannot connect to HQPlayer.

As long as selected audio output device is not accessible, HQPlayer won’t let Roon to connect and refuses to take any dropped content.

  1. Make sure your DAC is not selected as default audio output device for Windows
  2. Make sure you don’t have any other applications running at configured to use that device (such as Roon)
  3. Select your DAC in HQPlayer device selection, not “Default endpoint”

Okay. In the attempt to test HQPlayer alone, I was not able to drag and drop a flac file from Windows File Explorer, it just didn’t appear in the area that Jussi pointed out when I dropped. I could do a scan from HQP library and get a folder of flac files, but then I couldn’t play it. So much for the HQPlayer alone test.
Trying to control HQPlayer from Roon, with no Roon Zone enabled except HQPlayer, using my host’s local IP4 address instead of local host, since some have not been able to use the latter, but no one has said they had a problem with the former, and the HQ icon selected on both my Windows 10 host and my Android tablet, I try to play a file either from the host or the tablet, and I get the same message, Roon cannot connect to HQPlayer. Weird, I would have thought it was because HQPlayer cannot connect to PS Audio DAC, because neither it nor any other DAC appears in the HQP Device box. Does HQP just look for a DAC connected by USB to the host and then fill that in the HQP Device box? If so, I am screwed because my PS Audio Perfect Wave II DAC is connected to the host by Ethernet, into the PS Audio Bridge II inside the DAC.
What next? I’m out of ideas. I’m less upset that I’m out $260 if I can’t get it to work, than I don’t have the opportunity to use it, since I know how critical the filter settings are on the DAC chip (even though Paul McGowan says he can’t hear the difference between the 5 settings).
C’est la vie.

Well this is the problem here.

If the system layout was mentioned earlier we could have spotted this and saved you a lot of time :grinning:.

HQPlayer can play over the network but only to “NAA” endpoints.

Kind of like Roon playing to Roon Ready/Roon Bridge endpoints over the network.

Roon can see your Bridge II because the Bridge II network card supports Roon Ready. It does not support HQPlayer’s NAA protocol.

If you had a Raspberry Pi4 you could use that as HQPlayer endpoint (NAA).

So HQPlayer can play over the network but not directly to your Bridge II card.

Hope that makes sense? If not, just check what the Bridge II supports and you will not see HQPlayer NAA mentioned… it supports Roon, UPnP, Spotify Connect etc.

I assume your Roon Core and Bridge II DAC are not in the same room?

Apologies if I’ve guessed your system layout wrong here. Just trying to help

No, the host computer is in my study and the Bridge II is in the living room. Have any ideas as to what I can do to make it work?

Raspberry Pi4 with my NAA OS image connected to network, and to your DAC via USB.

Or alternatively something more fancy… (there are some NAA hardware options listed on my web page)

1 Like

Since I am already worried about sonic degradation from the USB connection vis à vis my current Ethernet Bridge II, if I got an NAA device, I would want no sonic degradation from it. What would be my least expensive option? Now the deal breaker? Since my Core PC device is 50 feet from my audio system, I assume I could not connect with USB from the Core to the NAA device. 16 feet the limit on USB? And the cost of the electrician to go under the house and replace the ethernet cable with a super expensive USB cable (?).
Just trying to see if I have any options other than moving my Core setup to the living room (not going to happen).
Thanks for all your attention! I assume there is a technical reason why you couldn’t make an ethernet friendly version of HQP (HQP.E?).

Jussi’s proposed solution is

HQPlayer PC > ethernet > Raspberry Pi running NAA image > USB > PS Audio

No need to run a long USB cable, just a 2nd ethernet cable.

1 Like

If there’s already Ethernet cable, it can be shared to multiple devices using an inexpensive unmanaged switch (for about 50€ you get a good one). HPE OfficeConnect 1420 8G:

RasPi4 is least expensive. And of purpose built NAA devices, iFi ZEN Stream is among the least expensive.

I appreciate this thread.
I had been struggling figuring out output.
I now have HQPlayer working with a Topping D50s. All driven remotely via Roon.

Anyone have a handy chart for all the filters and what they do?
Also. How do I reset to “factory” new after I fail to read and mess up my audio playback entirely?

Thank you.

1 Like

There’s a one in the included PDF manual.

In the Help-menu there’s an option to clear data. This will delete settings and on next start settings are reset back to default. At least at the moment, this doesn’t touch library data.

2 Likes