Getting intermittent individual audio pops during Roon playback on different devices - only started recently

Roon Core Machine

Macbook Pro Mid 2015
2.5Ghz Quad-Core Intel Core i7
16gb 1600Mhz DDR3
MacOS Monterey 12.1

Networking Gear & Setup Details

Core on ethernet
TP-Link Router
D-Link Network Switch

Connected Audio Devices

Devices problem noticed on:
Bluesound Powernode N330
Macbook Pro 2019 with iFi Zen Dac v2
Google Pixel 4a5G

Number of Tracks in Library


Description of Issue

At arbitrary points during a song, I will hear a “pop” that is not in the track. It will happen maybe once every song or so. It’s not constant and very brief, and is nearly impossible to replicate consistently, but it happens frequently enough and is enough of a distraction that it has made me think twice before using Roon.

I have heard this pop on multiple devices including my headphone DAC connected to my computer and over the Bluesound Powernode speakers. The computer is connected via ethernet, the Powernode over wifi.

The pop occurs on both local and streamed music.

This is only a very recent problem that I’ve noticed - within the last few weeks, but most notable in the last few days.

Nothing has changed with regards to the setup or function of the Roon Core system. I have tried restarting all devices including the router, switch, core and playback devices.

Any support would be greatly appreciated.

anything else running like time machine etc to cause some CPU glitches?

Nothing like that.

I have a Dropbox backup that happens every hour but that’s minimal, just backing up the music on the external hard drive. I set that up somewhat recently, maybe I should try turning that off and see if it makes a difference.

Doesn’t make a lot of sense to me though.

dropbox is being hit over the network so its very plausable that this could cause a drop in network performance.

Good point.

I just checked and it turns out Dropbox wasn’t active (probably hasn’t been on since I restarted the last few times).

It’s generally a totally idle computer, right now it’s saying 95% of the CPU is idle and 6 out of 16 gigs of ram is being used. That’s with me playing through Roon right now to test.

Any further support or anyone having a similar problem? It persists for me. I’ve tried all sorts of restarting, changing network cables, nothing fixes it.

I can’t help but feel this is something that has been introduced in a recent update .

Sadly if I don’t see it improve in the next few months I’ll have to let my Roon subscription lapse. Had been considering a lifetime subscription before the price increase but that’s absolutely off the table at the moment.

Hey @Elias_Nohra,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

As a next step, please take note of the date, time, and track the next time this happens, and share it here. From there, we’ll enable diagnostics to take a deeper look into things.

With that, I’d be curious to test out your network switch to see if that may play a role in this. If possible, can you try bypassing the switch and hooking up your core directly to your router? I would power cycle both your router and core after doing this.

You mention this happens no matter the endpoint. Is this the case when using different Roon remotes as well?

I’ll be monitoring this thread for your reply :+1:

Thanks, Benjamin.

The problem persisted despite a number of restarts and trying different network connections.

However it seems to have sorted itself out in the last few days. The only thing I did differently this time is instead of restarting the server computer as I normally would, I instead simply shut down Roon server software on the macbook, then reopened it. It SEEMS that since then it’s working ok?

Very strange, I know. Could the software behave differently from being opened at boot vs being reopened later?

I’d like to keep this thread open for another week or so in case the problem re-surfaces as the solution seems honestly bizarre.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.