Globally disable “radio” feature?


(Chay Wesley) #1

@support I can’t figure out how to globally disable the “Radio” feature. It’s forever playing stuff that’s inappropriate when children are around, and I want nothing more to do with it. Please advise, thanks.


(Mike) #2

Radio is on by default, but turning it off should be one click on the queue. You’ll need to do that once per zone, but Radio shouldn’t start automatically after that.

You can also disable the Start Radio buttons from Settings > Play Options .

Also, we’d love to hear what you didn’t like about Radio’s picks :slight_smile:

https://community.roonlabs.com/t/roon-1-4-radio-feedback/35686/16?u=mike


(Ludwig van Marbach) #3

There’s a separate feature request about turning it off globally, I think, because if you’re not a radio user, every time you reconfigure or add a zone you have to turn it off, and it gets old REAL soon… :wink:


#4

It is not about what kind of music is picked by ‘Radio’, it is the fact that ‘Radio’ is started automatically by default. Many of us don’t want that. @Ludwig points to the right option and thread.


(Simon Chick) #5

Yes. It should be off by default.


(Mike) #6

I understand the interest in a global disable here, and I’m going to look into getting that done. Appreciate the feedback, all.

I’d also like to understand whether this is about setting a preference, or if there’s a bug here that’s causing the switch to reset to On when it shouldn’t – are people seeing something like that, or are you just setting up new audio devices/zones on a regular basis?


#7

No. It shouldn’t


(David Townes) #8

I have had it come on randomly occasionally. I went into settings and turned them off, see what happens now. I’m an album or artist person. I will cue up the things I want to hear, when those have played I want to rest my ears before starting something else. That’s why I would like a global turn off switch which is easily accessed.


#9

Thanks for understanding @mike!
For me it is a preference. I have only one zone at the moment so I’ll leave possible bug comments to those with several zones that see this more often than me. As long as there is a global on/off toggle I don’t mind if it defaults to on.


(Ludwig van Marbach) #10

That’s not the discussion here, and I suspect team Roon would be unlikely to agree.

Being able to switch it off globally once, is what is necessary and doesn’t go against Roon’s plan.


(Simon Chick) #11

I could live with that too, so long as it then got rid of it.


(Chay Wesley) #12

Thanks for the reply. Following your suggestion, I turned off ‘start radio automatically’ in all zones except for one (I actually enjoy the radio feature when working in my home office alone). So far so good, but later I notice that the other zones in my house eventually end up with the ‘start radio’ setting reenabled. What I’ve discovered is that once one or more zones gets grouped with any other zone having the ‘start radio automatically’ setting enabled, the enabled setting will propagate to those zones and will be retained even when subsequently un-grouped.


(Greg Stratton) #13

Hi Chay,

This is awesome. It’s exactly what @mike and @support are looking for. They like to have steps to be able to reproduce an issue.

So, to summarize your findings:

  1. Start playing music in a zone that has Radio on.
  2. Group to a Zone that has Radio off.
  3. Grouped music plays to both zones, with Radio on, as expected.
  4. UnGroup Zones
  5. Previous zone which had Radio off has reverted to Radio on.

You would like the second zone to go back to Radio Off.

Hope that’s correct.

Edit: I should point out that I was able to reproduce this issue.

Cheers, Greg


(Chay Wesley) #14

Yes, that’s exactly correct.


#15

Even without grouping zones. Transferring playback from a radio-enabled zone to a radio-disabled zone results in the latter having radio enabled every time.

(In my case the zone with radio on is a Chromecast and the other is HQPlayer, if that might be relevant)


(Ron Kopito) #17

You can also disable the Start Radio buttons from Settings > Play Options .


(Anders Vinberg) #18

Removes it from the Play drop down, but not from the Now Playing queue display which is what is troubling people.


(Marco) #19

It’s still impossle to remove radio window on the right of queue window?

It occupies a lot of space on my iPad!


(Richard Levy) #20

Whether it’s on or off by default, one should be able to switch it on and off globally. There are times when I just want to listen to my albums and am not interested in having the radio come on. There should be a single click that disables Radio in all zones all at once. I don’t care what the default is. Just so that it can be done more easily.


(Adrian Laughton) #21

Spotify & Tidal both turn autoplay back on when they do an update (or have in the past anyway) so I was wondering if it was linked to this but sounds like it was probably just the zones issue that I hadn’t understood.

Personally I hate autoplay so am +1 for having off as the default but that’s just personal preference and I can see how Roon may think having it on as default highlights the feature.