GPU usage turns on my fans


I have 2 gpu in my laptop, the intel 630 and nvidia gtx1050, I’ve noticed my laptop fans start blowing loudly whenever a song is playing.
after a little checking it turns out that roon is using both gpu at ~10-20% and there is no way to disable it…? the only thing i see that visually changes is the playback position marker being drawn every pixel it moves, this can easily be done on a cpu and doesn’t even require a single gpu let alone 2 gpu.

Can this anoyance be turned off?
Can I somehow force roon to use 1 of the 2 gpu? skipping the gtx1050 would prevent the fans from turning on unless cpu/gpu load is crazy… just 1% load on my gtx1050 enables the fans.

Moved to support.

Roon is built like a video game using OpenGL and some laptop’s will sense that and auto-switch to using the Nvidia instead of the Intel graphics. You can go into Device Manager and try disabling the gtx1050.

Hi @Jan_Willem_Verzijden,

If you try setting Roon to be opened by the internal GPU do you still see this behavior? You can give this a try by using these instructions.

As @Rugby mentioned, Roon uses OpenGL to draw the interface, so it is very similar to having a video game running.

setting it to power saver does seem to select the intel 630 gpu, which keeps the fans nice and idle.
part of the problem might be the fact that gpu load is 4 to 5 times higher on a 4k screen compared to a fullhd screen.
why does roon need the gpu at all though, it’s not a video game rendering hundreds of thousands of textures on weird surfaces…
roon has massive load for a couple of updates every second, this shouldn’t hit the active cooling threshold in my opinion.

Roon uses a gaming engine to give the rendering speed so your PC may well see it as a game.

Hi @Jan_Willem_Verzijden,

Thanks for the update here. Since power saver is working as expected, I would suggest you keep using that mode.

Roon uses OpenGL to display the interface, and video games use the same type of architecture as Roon in this case.

I think I have found the thing that causes a lot of gpu load: playback is active icon (the 3 bars that keep resizing)
it causes my gpu load to increase from 0.3% to >13%, whenever I’m on a window without this animation it drops back down to 0.3% immediately

Yes, any active animations will necessarily consume more GPU.

see images below, its 1 animation that is doing this…

paused looking at the queue:

playback scrolled up in the queue:

playback with active song on screen:

now you can answer again with “but roon uses a gaming engine”… that’s besides the point. regardless of the engine used, you don’t use this much resources for a single animation.

the Intel Graphics 630 has about 400 GFLOPS of performance.
roon needs about 20% to render 1 animation that’s only like 50x50 pixels.
on my current system the cost of this animation is roughly 80 gigaflops of performance or in terms of power usage its only 3 Watt to animate a playback indicator.

that is pretty crazy if you ask me…

Hello @Jan_Willem_Verzijden,

I spoke to the QA team today regarding your report, and while your GPU usage here seems higher than usual, some GPU usage is to be expected when you have objects moving on the screen in Roon.

We attempted to reproduce this behavior on our end in the QA lab and we are seeing 5-10% usage with both a GTX 1050 and 1060. Since your usage is a bit higher than this, I would check to make sure that you are using the latest driver versions and your power settings in Windows are configured to High Performance.

The updated drivers and power settings might help optimize a bit of GPU, but again, when object on the screen are moving in Roon, it is essentially the same as rendering an object in a video game, and that requires GPU resources to do so.

1 Like

my drivers are up to date, however I have a 4k screen which might increase the load as there are more pixels to render. also my load % is higher because I enforce the use of the intel630 over the gtx1050 for other reasons.

The problem remains that this 1 animation takes so much resources its comparable to a video stream, except that a video stream requires the gpu to decode and render the fullscreen pictures at 24fps, where this animation is a repeating pattern of 24x32 pixels in size…

Besides my noisy fans, imagine having 1000 users leaving the queue open for 3 hours per day, everyday. then after a year the total energy used to render that animation was about 3MegaWatt. (if my estimate was correct to begin with, regardless of that even if it’s 10% of that its still alot of energy)

I think it should be possible to render this animation without causing a significant increase in load, when scrolling through the queue, for instance, the load can go up as the entire window has to be redrawn.

Video playback and game rendering are two different things and cannot really be compared, imho. Plus, I am sure that Integrated Intel GPUs have been optimized for video playback.

Try, changing your screen display resolution to 1920×1080 and see if that relieves the pressure on the Intel GPU. I run my HTPC at that resolution on my 4k tv and it does not produce any fan noise at all.

Why you saying that rendering a still image with a less than 50x50 pixel animation takes more than a game or video stream? That just cant be true… simply cant be true. It’s also not fair to say that Roon is a game because it doesn’t have thousands of polygons or textures to render it has 1 texture its rendering very poorly. That is what I’m complaining about, the insane load this 1 single animation is causing.

Obviously lowering resolution will cut down the performance loss making it ‘less bad’ but it is still there plus i want to keep my screen at 4k the way it’s intended.

A proper solution would be to optimize this performance so it’s actually normal or add an option to disable the gpu and do it all on cpu at the cost of visual performance (which I would be happy with).

Do with it what you want… I’m not going to use roon anymore unless I need it for work. Which then start my fans to display this stupid animation.

I’m just another user like you. I run my htpc at 1920 because I like it better when reading websites from my recliner 6 feet away. I was trying to be helpful and offer a potential work around solution.

Just to test, I set my resolution back to 4k on the HTPC, started Roon and played something to activate the animation. My NUC’s fans did not start, it was dead silent. The increase in total gpu usage rose only 4% from baseline. i5 w/ Intel Iris Pro 5200 integrated graphics.

Hi @Jan_Willem_Verzijden,

To be clear, this type of usage isn’t something that is seen by everyone who uses Roon. Roon’s rendering is built similar to the way a video game engine is, so it’s definitely a bit different than what you might see from other apps, and different GPUs and drivers are going to use different amounts of resources.

There aren’t any plans to change how our rendering works in the near future, but we understand that this is an issue for you and we’ve passed your feedback along to the appropriate teams.

1 Like

Can’t you use the nvidia control panel to fix the Roon process to the integrated gfx card?