Green line display artifacts in 1.8 [Intel Bug, Update Your Drivers]


1 Like

Same here on Win10(64) computer running Roon 1.8 (fuzzy image, see below). Roon server is running on separate machine (ROCK, latest ). No problem on iphone app.

requested info:

Roon logs from ROCK machine:

1 Like

What if you try using the 32 bit version. Previously, the 32 bit version worked when the 64 bit version had graphic issues on Intel 4th Gen chips.

I have so much love for Roon Labs. Thanks for working on this issue.

1 Like

Hello All,

Thank you for the screenshots and log info! For those affected by the issue - can you please confirm if you have the latest Intel Display drivers installed from your manufacturer or via the Intel Update Tool?

If running this tool resolves the issue, please let us know!

I have weird green lines appearing on the screen, unplayable… I have this issue only with roon, and only since the update


I updated the display driver on my windows 10 machine and now problem solved!

Here is the solution that worked for me. It does appear that you must have the absolutely latest version of the Intel graphics driver to get the latest version of Roon to display correctly, as least that was my experience. Specifically, Device Manager and Windows Update all reported that my PC had the latest version, as did Driver Easy. But that “latest” version is not the absolutely most recent version of the Intel graphics driver that was posted by Intel in late January – only about two weeks ago.

Some additional specific instructions that might help. The Intel driver support assistant link that Roon supplied above failed – the driver update failed. I then downloaded the driver manually from the link below. When I ran that driver update, it also failed and reported that I already had that version of the Intel graphics driver installed. But when I checked the graphics driver version number by comparing what the web site reports and what device manager says, it was clear that I did not have the latest driver installed. So I deleted the Intel driver that I downloaded. I downloaded again. Ran the update again. That time it worked, and now Roon is fine.

So if you are having this problem, download the latest Intel driver from the below link. You might have to download more than once and run it more than once. Again the Intel assistant tool failed in my case. So download the Intel driver manually and install manually.

One other tip – if you use Device Manger and ask it to update driver, that will NOT work and it will report that the most recent version is installed. I also use a program called “Driver Easy” and it also incorrectly reported that the most recent driver is installed – when it was not. So do not go by Device Manger and any other program.

Download the Intel driver manually; run the install several times as may be necessary; and with a little luck Roon will work OK.

I would also report that only the latest version of Roon had this problem. All other software worked fine with the previous Intel graphics driver – and that was a very recent version. So the latest 64 bit version of Roon appears to not be very flexible or tolerant of various windows Intel graphics drivers. The new version of Roon fails with a very recent version of the Intel graphics driver as reported both within Windows update; within Device Manager; and by Driver Easy. All of those reported that I already had the most recent graphics driver. But that “recent” version resulted in the same graphics problem reported above.

Only the absolute latest version of the Intel driver worked with the new version of Roon, at least on my PC.

Roon might look into this a bit more, as very recent Intel graphics drivers are failing – specifically the most recent graphics drivers as reported within Device Manager; Windows Update and Driver Easy.

With that said, hopefully those Roon users having this problem can solve it by downloading the Intel driver from the below line. Again, run it more than once as may be necessary.

One other tip: do not bother to download the 32 bit version of Roon. It will have the same graphics problem, at least that was my experience. I also downloaded the 64 bit version of Roon and reinstalled that. Same graphics problem reported above. The only solution that worked was to download the absolutely latest version of the Intel driver that was posted only about two weeks ago.

Warning – based on one report below, the latest Intel driver can cause more problems that it solves on some PCs. So your mileage may vary.

1 Like

Am I the only person this is happening to? Tried restarting / reinstalling. No dice.

Prescribed fix resolved the issue. Thank you.

Nope. Me, too.

Plus, ASUS says driver is up to date and Intel’s driver makes the system unbootable.

Thanks Adam. When I install, I get a message that unable to install driver as need custom driver for computer. I have HP. Went to HP’s website and installed their latest driver. Still no joy. Likely will need to wait for Roon Labs to come up with a solution that works with my display’s driver.

Driver Failed to Load (2)

Update. When in doubt follow directions. Followed the directions here on deleting and updating driver. Error Message Appears When Installing Intel Graphics Driver... Afterward, I was able to install latest graphics Windows 10 DCH driver and can now see Roon 1.8 in all its glory.

Thanks again Adam!

I entirely agree that the latest version of Roon is very finicky and not tolerant with regards to working with recent graphics drivers. As I reported, on my PC Roon failed with a very recent Intel driver – Device Manager, Windows Update and Driver Easy all said I had the most recent driver. And that resulted in the video corruption reported above. Only the Intel version from two weeks ago worked. But your computer won’t let you install it, and there is another report above that it made one PC unbootable.

My suggestion to the Roon development team is to test a new version on at least 20 different PCs of different manufacturers and ages. But maybe they did that and still didn’t detect the problem.

Adam. Again much thanks!!

I had to uninstall and delete my existing graphic drivers and then I was able to install the Windows 10 DCH Driver. I am now able to see and run Roon 1.8.

1 Like

This issue is caused by a bug in Intel’s GPU drivers that causes graphical corruption with applications that utilize 30-bit (“deep color”) frame buffers. We encountered this bug during the development of Roon 1.8, but it has been fixed in Intel’s driver releases since July or August of last year.

To update to the latest GPU drivers, use the Intel® Driver & Support Assistant.

If you cannot (or do not wish to) update your GPU drivers, you can disable 30-bit color on Windows by adding the -nodeepcolor argument to the application shortcuts that you use to launch Roon. You can access this setting by right-clicking (or shift+right-click on pinned task bar items) on the shortcut, selecting “Properties”, and adding the flag to the end of the “Target” field, like this:

There will be a very subtle drop in visual quality and the decrease in performance will probably not be noticeable unless you’re using a 4k display or have multiple monitors.


Thanks, It works after I manually update the Intel UHD driver.

After I managed to install the most recent Intel driver (see my previous post), I noticed that letters were dropped in some Playlist titles. So “Jazz Playlist” would be shown as “Jazz laylist” to offer an example. This only occurred on my monitor connected to my PC. The display was correct on iPads, so this was clearly related to the graphics card and driver on the PC.

Oddly, I only noticed this problem on the names of some Playlists.

I then added “-nodeepcolor” as recommended. That eliminated the artifact of losing letters.

I didn’t notice any difference in color depth or the display.

I usually have this happen when the Intel driver gets in a bad state, usually from some application using too much video memory. When this happens to me, the PC never seems to fully recover (the GPU starts behaving strangely in all applications). I’ve never been able to really resolve the issue without restarting the affected computer.

A post was split to a new topic: Roon App Crashing after fixing green screen

Has roon offer a repair yet?