Grouped airplay zones on Linux


My Roon Server runs on an Intel NUC powered by Linux. When I start playing music with only one Airport as endpoint, everything works as expected.
But Roon apparently cannot handle two Airports in this setup (there were no problems when I ran Roon Server on an iMac in the same network setup).
On the Linux box the player won’t even start when it needs to stream to two Airports. The play icon animates, but the timer stays at 0:00.
When I retry clicking the play button, one of the Airports will eventually output audio.
I have tried different Linux versions, but they all have this issue.
The problem is the same on all Roon clients I use: iMac, iPad and Android phone.

Tested setup:
Roon client on iMac
Version 1.2 (build 165) stable (64bit)
Roon client on Nexus Android 7.1
Version 1.2 (build 168) stable (32bit)

Roon server on Intel NUC6i5SYH, 16GB memory, 250GB SSD
Version 1.2 (build 165) stable (64bit)
Linux Mint 18.1 with 4.9.5 kernel

About 700 albums on a QNAP TS253PRO NAS.

So as I get no reaction on this subject, I have installed Windows 10 on the Intel NUC. Both Airports output audio.
Linux on this NUC is not an option for this moment *). By the way: it is the same NUC Roon proposes for their Roon Core Kit. I think there’s still some work to do.

I can’t wait to use this Roon Core Kit.

*) Maybe it is not just the Linux on the Intel NUC. Is there someone running a Linux Roonserver that outputs to more Airports?

I enabled two Airport endpoints (Airport Express & Apple TV3) and can replicate (server @NUC6i5 / Debian Stretch).

One is fine, two is troublesome, two grouped is the same as above (refusing to play or playing with audio out of one).

Pinging @support to take a closer look – there may be a Linux-related bug here.

We’re looking into this @Arie_van_Boxel – thanks for the report!

FYI: This issue isn’t fixed in Roon 1.3

Yes, we know. This issue is still under investigation. @Arie_van_Boxel can you specify the model of your AirPort ? Also do you have other airplay devices (other than airport) ? If so, would you mind to try to reproduce same issue with them ?

I use two Airport Expresses (
@vova, yes, I have tried my Apple TV 3d generation, but the same thing happens.
I have noticed that, when I de-grouped the Apple TV in the Roon Client, the Roon Server restarted: the connection was lost for a moment.

What a pity. Still no fix for this Airplay issue in Roon 1.3 (build 203)…
Yes, the 1.3 build added a lot of nice features. Maybe now the time has come to prioritize fixing long-running bugs.

I’m having trouble creating a stable Airplay group.
My setup is as follows: Roon core running on a QNAP TVS-471 which is plugged into a Netgear Nighthawk R8000 router, which allows 5GHz and 2.4GHz bands. The router then streams to a Bowers and Wilkins A7, 3 Airport expresses (1 current generation, the other 2 one generation back). I also stream to a Naim Muso.
All of the devices show up as Airplay devices on the Roon core, all are on the same network. The A7 and Naim can only use the 2.4GHz band, the Airport Expresses and use one of my two 5GHz bands, or the 2.4 band. All are current firmware.
If I access each device individually it will work flawlessly. If I try and group more than 1 Airplay compatible device it is not stable. Have tried using different wifi bands, the same band, any combination of products, and then problems ensue.
If I begin streaming to one device and then add another to create a group zone it generally works. It doesn’t seem to be a network flow issue as there is no issue with dropouts once it’s working.
However, if I quit Roon or transfer a group zone to another device and then come back to the original group one of two undesirable things happen: a: no sound output through either audio device with either the track advancing or not in the bottom bar or b: one device will stream but the other one will not.
I don’t think this is problem with my network for 2 reasons: 1. it was stable prior to Roon 1.3 and 2. the Roon was stable to streaming to all 5 Airplay devices at once through my MacBook Pro Touch when I was running the Roon core off the MacBook rather than the QNAP, which if anything should be better.
Would love some help on this as it’s rather frustrating to have what looks to be a stable group zone setup only to have it fragment or become non-functional as soon as I switch individual endpoints or zones or close the Roon app.

1 Like

Hi @john_lingertat ----- Thank you for the report and my apologies for the troubles here.

In your troubleshooting of this issue have you tried temporarily running your Roon core on the MBP touch again? If so was the experience any different when grouping your Airplay zones or were you seeing the same results?


Good thought. When I’m next home I’ll switch the core back to the MBP and let you know what happens. Didn’t think to do this as the core was stable to multiple devices as a zone on the MBP, but with software updates and now running the core on the QNAP who knows… it will let me know at least if it’s a connectivity issue or internal software one.

1 Like

Have done the switch. The Roon core is stable on the MBP streaming to 5 different endpoints, 3 Airport expresses, B&W A7 and Naim Must with no dropouts or loosing zones or output to zones when I change zone settings or endpoints.
The previously described problems persist when I run the core through the QNAP. What next?

@john_lingertat what spec is you Qnap?


QNAP TVS-471. 512GB Adata SSD running roon core. Western digital reds 6Tb store music in bay 2. Bays 2,3 as RAID structured as RAID 1, 4th bay Western digital red 6 TB to back up the RAID 1 which holds my audio files.
Should I try running the core under linux off the QNAP as a virtual machine? Could potentially install an old copy of windows 7. Would prefer not to go these routes but will do so if the problem lies in the build for the QNAP.

Sorry I meant what cpu does the Qnap have and how much memory?

intel R core i3-4150 CPU @3.5GHZ, 4GB RAM

How does that spec compare to the Mac that shows no issues, have you monitored the Qnap when you run core on it to see if it is running near any limits? Qmanager app for the iPad will let you do this, it is free.


When I run 3 streams to airplay endpoints from the QNAP the CPU utilization hits a max of 15% of the CPU and the RAM utilization is at 35% -so it’s not a limitation in the processing power of the QNAP. The status bar at the bottom of the roon shows green on all the streams as well.

Mac is an intel core i7 16GB RAM.

Wonder if you’ve had a chance to look at this issue. Would rather not go the route of using a virtual machine on the NAS for the sole purpose of what seems to be a software issue. Awaiting your reply. Thanks.