Grouped airplay zones on Linux

Hi @john_lingertat ---- Thank you for performing the proposed test and sharing your feedback with me. Apologies for the delayed response.

Can you verify for me if jumbo frames are engaged on the NAS and if they are, may I ask you to please disengage them to see if this yields a change a behavior here.

Lastly, can you also confirm if you are using any type of port aggregation in your setup.


Reminds me of the problem I posted a while ago:
I think this issue deserves priority as many of us use Roon with Airplay.

I don’t see a way of eliminating jumbo frames on the NAS, only changing their sizes.

I don’t appear to be using port aggregation. See attached.

The comment by Arie van Boxel doesn’t seem to apply to me, as Roon is stable when I run it through my MacBook pro with multiple airplay endpoints.

I thought it would apply to you too, because you run the Roon core on a Linux server (the NAS). I also did not have the problem when I ran the Roon core on an iMac.

Thanks for the input. I do think its an issue with the software build for the QNAP. Really would like this issue fixed as I spent a fair bit of money for a relatively high end QNAP meeting the specs as recommended by Roon only to have the system be unstable with more than one Airplay endpoint.

Hey @john_lingertat @Arie_van_Boxel

I’ve merged these threads since they appear to be the same issue. We looked into this a while back, and we were able to get grouping working with 5 different Airplay zones running off a Linux Core, and since then the ticket has been languishing, since we’re not able to reproduce.

Obviously, something is different about our setup from yours, since you both (along with @RBM) are able to reproduce consistently. This is probably going to be something environmental – the router you’re using, the types of Airplay devices you’re using, your wifi signal strength, etc. We just need to find the common thread, then we’ll be able to fix this once we see it happen in house.

There’s a lot of info in this thread, so Eric and I are going to pull this together and see if we can identify any common threads. It would be great if you guys could try to modulate the problem as well, for example:

  • Does this happen with every pair you have on hand (aka Airport Express + A7; Airport Express + Muso; etc)
  • Does this happen with wired connections and wifi?
  • Does this happen with different routers?
  • and so on

The more information we have here, the more likely it is that we’ll resolve this guys. Just know that the ticket is open in our system, and we’re looking into this. Thanks for your patience all!

1 Like

The problem occurs regardless of pairing: airport to airport, naim to airport, airport to A7. Because of the physical layout of my house, I have been using wifi connections to all of my devices, haven’t tried wired, because it doesn’t meet my needs. When I have time I’ll attempt running it through my 3TB TimeCapsule to see what happens, and will let you know.
If it is of use to you I can allow you remote access to my QNAP to see whats going on. You can contact me via by Roon subscription email and I could provide you with remote access - obviously I would need to know it’s coming from you prior to providing remote access to my system.

Hey @mike,

Just did a little testing for testing’s sake and found no change.

Roon Core @ Linux NUC
Airport Extreme (last gen)
Airport Express (last gen)
Apple TV3

Express & Apple TV connected to Extreme over WiFi, all within a few meters and in line of sight. As for bandwidth: I can stream DSD256 via the Express to a Cubox/Mojo combo without problems.

Express and ATV play fine individually. When grouped, nothing plays – progress bar remains frozen at 0:00.

Just adding a data point here for troubleshooting purposes.

EDIT: adding a little more data – I just read @john_lingertat’s comment about adding a zone to one already playing. When I play to the Express and add the ATV while the Express is playing, it works for a few seconds, then client (macOS 10.12.3) loses connection to Core for a few seconds, after reconnecting automatically it reloads the zones and shows the grouped zones with audio stopped – consistently.

Would be happy to set up a time to allow you to have remote access to my system - would prefer to allow you access through Chrome Remote Desktop and allow you to see the issue directly and allow you to see the issues affecting the system directly as I don’t think I’m alone in this.

I have somewhat of a similar issue. When I add to a zone that’s already playing I can add one other unit, which remains stable for output, but as soon as I migrate from this zone and then back to it there is no output at the end points - either the music scrolling stops and won’t restart, or the music track will advance with no output. The streaming connection however still shows green in the status bar at all of the end points.

Hello @mike,
I also did some tests with the AirPorts. Both are the latest AirPort Expresses.
Roon Server on Intel NUC, client on iMac.

  1. I start with only one AirPort powered on. Everything works as it should.

  2. I power up a second AirPort.
    When it comes online I group this one with the one already playing. Now both AirPorts are outputting sound.
    Everything is still OK. I can pause and resume the music.

  3. I transfer the audio to another zone (without AirPorts). All fine.

  4. I transfer the output back to the AirPorts zone. None of the AirPorts sound anymore!

A start-stop in Roon takes a very long time to react, but just the first time. Only the last added AirPort outputs sound.
I can’t get the other one to work again and have to restart the Roon Server the get the first AirPort back online.

Thanks for all the details everyone.

Since the Airplay Express appears to be a common thread in many of these reports, we ordered one yesterday. Hopefully it yields some nice crisp reproduction steps so we can figure out what’s going on here.

We will follow up once we’ve done some more testing everyone. Thanks again!

You may want to have 2 Airport Expresses, as streaming to one hasn’t been an issue (at least for me). The problem arises when more than one airport is in use, so a single airport endpoint may not reproduce the issue for you.

As all failure scenario’s include at least one Airport Express, getting one and test it together with other Airplay endpoints should lead to replicable results.

Hi. It’s been a little while now (March), and I’m still suffering from the same issues as before. Any update on resolving this problem - still can’t create stable multiple end points to Airport expresses, with or without my B&W A7 in the mix as a grouped zone.

Probably there aren’t many people that use more then one airplay device. I started this topic half a year ago. No high priority in solving this issue.
I am using ROCK now, but ROCK being Linux still suffers this same problem.
macOS and Windows do not have this problem. Is it an Apple thing not supporting Linux?

Hi @Arie_van_Boxel and fellow airplay users ---- I just wanted to take a moment to update this thread.

Myself along with our QA department have been actively investigating this behavior since it was reported to us. While I agree, that this issue has taken us longer than we would like to determine the cause, rest assured that we have not given up :microscope:

Currently, we are seeing a variety of outcomes during our testing and are vigorously trying to make this behavior 100% reproducible each time so our developers can understand and ultimately fix this problem.

Our team has GREATLY appreciated everyone’s feedback and more importantly your patience, while we have been battling with this issue.


1 Like

Glad to hear!

1 Like

3 posts were split to a new topic: Cannot play to airport express group in sync