Grouped HomePods issue

I’m in the same situation… I look forward to this being resolved.

Hi @Christopher_Johnson1,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.


1 Like

My apologies for leaving out critical details! After the most recent update, I have not been able to playback music via my Grouped Homepod minis. Playback to any of my Sonos speakers works fine - it’s just the HomePods that have been impacted somehow.

  • Core machine (Mac OS 11.6 Big Sur, Mac Mini M1, Roon build 831)

  • Remote(s) (iPad OS 15.0 & iPhone OS 15.0, 12" iPad Pro and iPhone 12 Pro Max) Roon Remote Build 831

  • Networking details - Roon connects to all speakers over WI-FI / Airplay.

  • Audio devices in use: There are no amps or special equipment - just a Mac, an iPad and a crap ton of Sonos speakers here and there, plus two paired homepod Minis.

  • Library details (music is stored on Mac local ssd and in Tidal)

Thanks for the update, @Christopher_Johnson2.

Are you grouping the HomePods in HomeKit? Does this happen if you’re not using HomeKit for this?

1 Like

@Dylan , yes, I have grouped the HomePods in HomeKit since day 1. This has not changed. Are you asking me to break the HomeKit “pairing” and group them in Roon instead?

I ungrouped them in Homekit and have grouped them in Roon 0 and they are working as desired!
Thank you!!!

Thanks for confirming, @Christopher_Johnson2! We’re looking into why Homekit grouping has stopped working. AudioOS 15 came out right around the time of our release, so it may be related to that. We’ll keep you updated once we have more info.

1 Like

Very interested to see about a resolution other than ungrouping the Homepods in Apple Home.

@Christopher_Johnson2 Grouping them in Roon without HomeKit’s stereo pairing will just give you two speakers simultaneously broadcasting the same signal with both channels (assuming you are listening to stereo music). Users here have posted a workaround by using Procedural EQ (through the DSP settings) to mute the left channel on the right speaker and the right channel on the left speaker, to get an approximation of stereo effect, but in my experience the result is unsatisfying and the stereo separation in some cases is lacking.
@digitalzed Agreed that ungrouping in HomeKit does not solve the problem and it shouldn’t be considered solved in these forums.