Grouped Homepods Will Not Play After Latest Update

Roon Core Machine

ROCK Version 1.0 (build 227) stable

Networking Gear & Setup Details

Linksys Velop Mesh Router AC2200 ethernet connected core and primary endpoint

Connected Audio Devices

Mac Pro (late 2013) Big Sur 11.6 endpoint USB audio out

Number of Tracks in Library

35,935 tracks

Description of Issue

After applying the latest September 2021 Roon update I am no longer able to play to grouped Homepods. I can successfully play to the individual Homepods. I am also able to successfully play to other audio devices, grouped and ungrouped.

The RoonServer Logs are available at:

1 Like

Thanks, @Ronald_Record! I’ll get the logs over to the team. I appreciate the report and we’ll follow up soon.

A post was split to a new topic: Grouped HomePods issue

Hi @Ronald_Record,

We’ve done some testing on our end but we haven’t been able to reproduce this on our side. When we try to group HomePods they’re working okay, so there’s likely an extra factor that we aren’t aware of just yet that we need to identify.

First, can you confirm the firmware version that your HomePods are running? Are they fully up to date?

Additionally, we’ve enabled some additional Airplay logging on your account that will help us learn more about what’s happening. I’m hoping you can do the following:

Please reproduce the issue and note the exact local time + date when this occurs and the name of the track that was playing and upload your Roon Logs by using these instructions. The best way to get them over to me would be via Dropbox / Google Drive, but if you don’t have either service please let me know and I can provide alternate upload instructions.

Hi Dylan, thanks to you and your team for helping me to track this issue down.

All of my Homepods indicate version 15.0. I have one Homepod and two Homepod minis. The Homepod minis are grouped in Homekit to provide stereo output. In Roon I group all three but grouping any two also exhibits the problem.

At approximately Thu Sep 23 10:02:09 PDT 2021 I reproduced the problem with all three Homepods grouped in Roon attempting to play the track “I Love My Computer” by Bad Religion off their album “The New America”.

Here is a link to Dropbox for the compressed Roon Server Logs:

1 Like

@dylan I have performed some additional testing with grouping my Homepods. I have two Homepod Minis and a standard Homepod. All play successfully individually. Grouping either of the Minis with the standard Homepod also plays successfully. The groupings that fail to play are grouping the two Minis or grouping all three - the two Minis and the standard Homepod. So, it looks like any grouping that includes the two Homepod Minis fails to play but any grouping that only includes one Homepod Mini works.

The tests I performed this morning were all with the track “Elephant Talk” off of the album “Discipline” by King Crimson. The dates of the tests were as follows:

Fri Sep 24 09:55:39 PDT 2021
All 3 grouped - fails to play

Fri Sep 24 09:56:30 PDT 2021
Homepod - plays

Fri Sep 24 09:57:17 PDT 2021
Homepod Mini Left - plays

Fri Sep 24 09:57:42 PDT 2021
Homepod Mini Right - plays

Fri Sep 24 09:58:23 PDT 2021
Grouped Mini Left + Mini Right - fails to play

Fri Sep 24 09:59:07 PDT 2021
Grouped Mini left + Homepod - plays

Fri Sep 24 09:59:54 PDT 2021
Grouped Mini right + Homepod - plays

Fri Sep 24 10:00:46 PDT 2021
Grouped Mini Right + Mini Left - fails to play

The compressed Roon Server logs from this time frame are available at:

Thanks so much for the detailed report, @Ronald_Record! I really appreciate this. I’ll get this to the team for analysis ASAP.

@dylan One more test. I ungrouped my Homepod Minis in Homekit. Grouping them in Homekit enables the two speakers to function as a stereo speaker system so I really wish to keep them grouped. However, ungrouping them in Homekit and then grouping the two Homepod Minis in Roon worked. So it may be that the issue we are seeing with grouped Homepods is tied to Homepods that are grouped in Homekit to provide stereo output. I believe the other person you are working with on this problem also has his Minis grouped in Homekit.

Prior to the most recent Roon update my Homekit grouped Homepod Minis were working just fine in Roon when grouped with my standard Homepod. Something in the update broke the Roon grouping of Homekit grouped Homepod Minis.

1 Like

I ran into the same problem with my 2 original HomePods. After the last Roon update and also the HomePod upgrade to v 15.0, I was not able to play music on the grouped HomePods in Roon.

As soon as I unpair them in Homekit, it works in Roon.

The setup in Roon is grouped and on individual HomePods, I switched off the “other channel” in the Procedural EQ to get a good stereo image. As soon as I activate stereo mode in HomeKit it stops

Hi @Mark_Simons ,

If you have time, could you provide details on how you ‘switched off the “other channel” in the Procedural EQ’ ? I would like to do so as well as a workaround for this bug while it is being fixed. I poked around a bit and did not see where in the DSP settings for my grouped homepods this was an option. Can you point me to the path to this setting? Thanks.

Volume > DSP > Add Filter > Procedural EQ > Add Operation > Mute Channel

Assuming all your music is 2-channel, switch off right channel on the left HomePod and left channel on right HomePod!

@Ronald_Record let me know if this works for you


@Mark_Simons thanks! This appears to work well. Hopefully we can get it working with Homekit grouping as well so those of us who use both Roon and Apple Music won’t have to adjust our grouping every time we switch between environments. It’s a good workaround for now.


or integrate Apple Music in Roon!

1 Like

Please see our update on this here:

Good afternoon, and good luck. It has happened to me and it has happened to me exactly the same since the last update. The HomePod’s individually work for me but grouped together, as I have always had and working perfectly, now REPRODUCTION is IMPOSSIBLE. As soon as I can I will proceed to ungroup the stereo pair in HomeKit and I hope it works for me and I can group them again in Roon. Greetings and thank you.

1 Like

Good afternoon again everyone. I just got home and proceeded on HomeKit to ungroup my stereo pair. The other five HomePods had them individually. I have entered my wonderful Roon, I have proceeded to group the seven HomePods, I have looked for my music, I pressed play and the magic has reappeared, that is, now they all work perfectly, as they always have. Thank you very much for the information that has helped me solve the problem. Again, thank you so much. A big greeting from Spain to the entire wonderful Roon community.

1 Like

Many thanks to @Mark_Simons for his creative workaround. Works great, particularly since, if left to my own devices, I would have never discovered his solution. Many thanks.

I have to disappoint you but this does not work. It only works when one uses the speakers separately but as soon as you link them into a zone the L/R separation is no longer there. Try it with a proper stereo-testing soundfile.
This is clearly a Roon Problem. If one links the two homepods in the Apple Homepod app the two pods are clearly separated as left and right. As soon as one links them together in a group it goes wrong. Visible in Roon as a group but NOT working.

I have noticed the same issue as @RJ_V mentions.

Two HomePods, grouped in Roon (but NOT grouped in HomeKit) that are set to be a L and R channel using the Procedural EQ method do not just play L and R channels on the respective speakers, tested using as stereo setup test file. If I un-group them, keep the DSP in place, and play the test file on each speaker individually it works as expected, so the Procedural EQ is set up correctly on each speaker. However group them again (in Roon), play the track again, and the seperate L & R channels both image in the centre, so each is coming from both speakers :frowning:

So currently there is no way to use these as a stereo destination in my Roon system :cry:

Hey @Rockster,

Thank you for explaining in detail what you’re experiencing.

I believe this is expected behavior: stereo pairing of HomePods is dependent on AirPlay2 and, currently, Roon only supports AirPlay: