Grouped Zones cause Display Issues?

After months of working flawlessly, I’m now seeing issues with the Ropieee display (currently running version 181).

I have two RAAT zones grouped together, and the Ropieee display tied to one of them. I’m seeing issues such as:

  • The display doesn’t update with the currently playing album.
  • Pressing Play will start the album playing in the Grouped Zone, but the play icon doesn’t change to the Pause icon.
  • The Play/Pause action will start and stop the music, even when the wrong album is being displayed, and the icon doesn’t change.

I should perhaps add that I’m running Roon Core build 354 on ROCK

Just sent feedback: d3d3c0fc2c14f744

I have had issues off and on since a Roon update a few months ago, and our normal situation is a grouped zone of two endpoints. My course of action that always works in my environment is to reboot ROCK, and then things are fine for the evening (usually).

I have noticed that since RoPieee v181 that the extension seems to be restarting periodically…I am not sure if Harry is doing more checks or not.


Yeah I implemented a few more checks. But the result is still far from ideal unfortunately.

@Geoff, thanks for the feedback.

1 Like

And in another thread, the solution seems to be: restart ROCK

Restarting ROCK is not a permanent solution, unfortunately. The issue (display not updating) returns. I’m currently running the beta of Ropieee…

@Geoff_Coupe But what is 'display not updating" exactly? What do you see?

It’s showing the album I was playing yesterday, and no longer showing the albums I’m playing today…

can tou send me feedback?

@Geoff_Coupe… I’m assuming that you have more than one core on your network. If so, try this.

  1. Ungroup the zones and focus only on the one that has a display tied to it.
  2. Make sure both cores have the zone defined and have something in their queues for that zone. Start fresh playback from one core and make sure that the display is updating.
  3. Restart RoonServer on the other core.
  4. Keep an eye on the display and see if it starts acting strange (locks up on the next track change, for instance)

Hi Andrew, it’s true that I have more than one Core on my network. However, I have never enabled extensions on more than one Core, and that has always been the “production” Core. The issue is appearing even though only the “production” Core is currently running.

Still, I’ll try what you suggest to see what happens. May take a day or so before I can do this… Thanks.

Harry, feedback sent: c45e0b3ec52512df

I noticed that, following an album change 30 minutes ago, the display finally started showing the current album playing, however, the controls did not work (i.e. Play/Pause did not respond).

This is strange. That feedback never arrived.

Ah. I’ve since downloaded a fresh beta. I’ll need to play a few albums and see if the issue recurs. Will do it tomorrow. Thanks.

I have the same thing, screen shows first album played but wont update

beta 205, screen only, one core, nothing grouped


edit: after reboot it shows the correct album now playing, but again it wont update. Also my settings on the screen itself (brightness and scrolling text) are not saved/forgotten.

can you restart the extension?

Did it, still not updating

pushed out an update. Just before the F1 finish :wink:

@Dick_Vliek, can you retry? this gives me a little bit more debug info.

Regards Harry

OK rebooting now

unfortunately still not updating. Also scrolling text again, card fried?
Verstappen won I presume ?


Verstappen was second. but starting from 18th :slight_smile:

Anyways, your unit updated. Nothing wrong with your SD card. Can you reboot? I see something weird in the logs, trying to figure out if this is a repetitive thing.

Regards Harry

1 Like