Growing increasingly frustrated with ROON

Roon Core Mac Mini runing Catalina

2nd Roon Core on custom Linux machine

As of late I’ve started to have issues syncing with Tidal, where when I manually force a Tidal sync it never seems to finish. This is happening on both my Roon cores. In addition to this I have another ticket open for constant iPhone app crashes as well. For premium software that I am paying over $100 annual I expect a more consistent “it should just work” experience. Not a happy customer.


How about giving some more information about your whole setup such as network, endpoints etc. Without this info support or anyone else is unlikely to help or find the root cause of your issues. I have used Roon and Tidal for 4 years without any issues so it’s likely this is something in your setup that’s changed that might be causing the issue, or even the isp. Have you changed anything network related such as router, firewall, cables or ISP since this issue started?

He has a ticket in with support and he’s not alone experiencing iPhone issues, there have been numerous reports.

For Tidal issues?

These are Tidal issues unique to Roon’s particularly unreliable integration with Tidal. Since this integration is a marquee feature of Roon it’s a very legitimate complaint to have.

I get if you don’t you Tidal this doesn’t bother you. For those of use that do however it’s serious.

You don’t need to look in this support forum very long to see a trend of recent issues unique to Tidal integration and there’s been no formal statement by developers that anything is amiss.


Now here is the real issue you and other users say “unreliable” but what about the uses that don’t have any reliability issues, Tidal integration has been rock solid for me and I have been using it for at least two years. I live in Australia and have moved home to another interstate location, still no issues.

I hope that these reliability issues for users that are experiencing them can be fixed but tracking down issues that plague a minority of users has to be very difficult and time consuming, perhaps many of these issues are network related?


All you have to do is review the issues in this forum. There’s a variety of issues effecting Tidal support (syncing, playback, login) and the solution typically offered by support is a restart of the server or a reset of the Tidal integration. However, those aren’t solutions- they’re workarounds for a bugged system. Nothing is really solved.

Maybe some of these are network related. Why doesn’t Roon have network diagnostics built-in to determine if the relevant cloud resources are accessible? Roon’s integration is unique, so it needs it own support. It’s been shown repeatedly that even if Tidal is working fine on a system, that doesn’t mean Roon’s integration with it will be.

These (network?) errors are unique to Roon so the onus is on them to support their paying users throughout the process of solving them. Obviously some users don’t feel like that’s being done. I’m sure that Roon’s aware of the issues, but the continuous suggestions of “just reset the integration”, while not publicly addressing that there’s a deeper problem, doesn’t give the impression that rock solid Tidal support is a priority.Tidal-centric users then question their purchases.

Hi @Rehan_Ashroff — Apologies for the trouble here!

So we can better assist you, can you describe your networking setup? Is it the same for both Cores or are they on two separate networks?

Is any new content added in TIDAL syncing at all?

Hi @dylan

Please see the screenshots below. I pushed a few new playlists to Tidal using, confirmed the playlists showed up in Tidal using my BluOS app and the native Tidal app. I then went to Roon>Settings>Services>Tidal and initiated a manual sync.

You will notice it says last sync was 905AM PST, I initiated the sync at 914AM, it finished at 916AM but the last sync time is still the same ?
Regardless I decided to go ahead and search the for playlist/s I was looking for and this time I was able to find them. My frustration here is that as of late the sync has been unreliable where it just keeps spinning endlessly and not updating with my latest playlists from Tidal.

When this happens I just fall back to using my BluOS/Bluesound app which ALWAYS finds my latest playlists and also allows me to sort them by date created so it’s so much easier to find. I’ve attached screenshots of that as well. I know there is nothing wrong with my network because as I’ve stated everything “just works” if I use the BluOS app, but the whoel reason I signed up for ROON is because I prefer the interface to BluOS.

My primary core is on a mac mini connected via ethernet to my router. The secondary core is also connected via ethernet to my router, it has Roon running on Linux Open Media Vault server.

I don’t want to muddy the primary issue here which is inconsistent behavior with Tidal sync, but if Roon could implement Tidal Playlists similar to how the BluOS app does, so you can browse them in real time and sort by date created it would be a huge improvement.

Hi @Rehan_Ashroff,

The next time that you notice an issue with TIDAL syncing where it just spins endlessly please make a note of the time you see this occur. We can then enable diagnostics and take a look at what’s occurring during this time.


A post was split to a new topic: Several issues with setup

FWIW I’d like to say that Roon staff eventually got around to helping me with my issue and it was resolved. Hope it’s smooth sailing from here. I really really do like the product or else I would’ve just moved on to something else.

It would be good to post a link to it, I think it will add some context.

@dylan happened this morning at 6:54 AM PST 02/12/2020 . I will keep testing again.

Hi @Rehan_Ashroff,

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Ok thanks!

Hi @Rehan_Ashroff — So we can verify that we’re looking in the right place in the diagnostics report, can you confirm which Core machine you were using at the time?

It’s the Mac Mini core named Casadolcemini. Tried a sync again now and experienced the endless spinning. 718AM PST 2/13/20.

Thanks, @Rehan_Ashroff. I’ll make sure that the team specifically reviews the report for this device and I’ll be sure to follow up when I have their feedback.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.