Half my library missing

Okay, So Roon has ‘imported’ my Library folder into its library. And it tells me I have 746 albums and 9902 tracks. In fact I have 1515 albums and 25725 tracks (and this is reported accurately by all other software - Audirvana, JRiver, MinimServer, HQPlayer). So how can I find out which albums Roon is not ‘seeing’? And how can I improve this? I don’t want to go through about 16000 tracks or over 750 albums manually identifying music that is already accurately identified by its internal metadata.

I can see there are numerous misidentifications amongst the albums it is showing me. For instance, it tell me I have and album by Kylie Minogue (an offensive accusation as far as I’m concerned!!) called LocoMotion, with the single track composed by Carole King and Gerry Goffin. In fact this is a one track album played and composed by the guitarist Lawson Rollins.

I’ve come back to Roon after abandoning it after its first release because of similar issues. I returned to it encouraged by comments about its improved use of the metadata already in the files. But this is not an encouraging start.

@Peregrino

Launch Roon.

Click Albums.

Hit forward slash “/”

Scroll to the far right.

Choose Inspector.

You can select Banned, Corrupt, Duplicates, Hidden, et al to examine the state of your Roon Library. This might aid in trouble shooting.

Hi Peregrino,

Are all the albums in your library in file formats supported by Roon ? Roon will not show multi-channel formats for example.

Thanks I’ll give this a go.

Files are all stereo, flac, dsf, a few dff, wav, and a few mp3.

Dff isn’t supported by Roon.

In case you have a lot multiple versions of one album als toggle the hide duplicate albums switch under settings. I once pulled my hair out with the same, only to find that it had to do with this simple issue.

Also in case you are using a tablet with a core and a remote all instances can show different statistics, since all instances can be configured independently. So making a change on the core is not propagated to all others, which is by design.

I’m sorry for not spotting this, but the problem seems to be the SMB file sharing between my QNAP NAS (453-mini) and my MacBook Pro. I usually use AFP for file sharing, which seems to work better and quicker on the Mac, but of course for Roon I have to use SMB. Trouble is that however I fiddle with the QNAP Network discovery and file share permissions settings, my MacBook only sees about 1.1 TB of the 3.1 TB music library folder.

I realise this is not therefore a specific Roon problem (except that Roon is the only thing I want to use SMB for), but if anyone has any clue what exact settings I need on the QNAP to make all the files accessible, I’d be very grateful.

Nobody can help with this?
I can see from the Roon forum that there have been continual problems with SMB mounts on MACs that closely resemble my problem. I’ve already tried all of the suggested (but apparently rarely successful) suggested solutions) and the situation remains unchanged. I see that an upgrade halfway through last year was meant to help, but users were reporting similar issues in November.

One of the problems with finding a common cause is that I can’t see a way of identifying which tracks are not imported other than going through the whole library.

It looks like Roon won’t work for me until an alternative mounting solution is found.

I have none of these problems with any other music software.

Let’s drop a flag for @mike and @vova and see what they can find out.

I would offer assistance but I have a Synology NAS and not a QNAP so cannot provide guidance there. On the Synology NAS enabling SMB3 made a sizable performance difference from the default of SMB1, this is with a Mac Mini. However as you noted your issues seem related to permissions for which I don’t have expertise to offer. As noted in previous post, hopefully @mike and @vova can assist.

BTW are all of your music files on one volume of the QNAP under one directory ( folder )?

Mine is on one volume, under a a folder called /music.

Hi @Peregrino,

One thing you can try is disabling AFP altogether on your QNAP. However, I don’t know how this might affect other applications you use your QNAP for. To do so:

  1. Enter your QNAP’s IP address in your web browser and log in
  2. Click Control Panel
  3. Under the Network Services header, click Win/Mac/NFS
  4. In the Microsoft Networking tab, make sure the box next to “Enable file service for Microsoft networking” is checked
  5. In the Apple Networking tab, uncheck the box next to “Enable AFP”

After you’ve done this, you should try re-watching your NAS drive in Roon, so first remove any other watched folders that you previously tried to set up (next to the folder click the settings icon > remove).

Make sure you’ve got the right IP address for your NAS and know the path to where you keep your music, then add a networked watched folder in Roon like this: smb://your NAS’s ip address/music. Mine looks something like this: smb://192.168.1.120/Music

Let me know if that works for you!

Hi Kevin,

Thanks for your help. In fact I had tried all that, but tried it again, with no change in result.

But I’ve since tracked the problem to illegal characters in file names, which has affected none of the other file formats I’ve used, but upsets smb and prevents them showing in Finder. So I’ve been batch editing (one set of) my music file names, and now the Roon library is missing only 15 out of my 1517 albums. I found most of the problem files by comparing folder sizes in an external hard-drive back-up of my music library with the smb-mounted folder in Finder. And I’ve just identified the missing 15 by adding the back-up folder to my Roon library and then seeing which ones weren’t duplicated.

Tomorrow I’ll check the file names of the tracks in the missing 15 albums. And then I’ll check the track count in Roon with the back-up to see if that tallies, or if I have further errant characters lurking somewhere.

best
Craig

In case it might help others, are you able to advise what the problem characters were ?

Yes. I tried to make sure I’d eradicated the usual characters that Windows doesn’t like in filenames:

/ \ . , [ ] { } ( ) ! : ; " ’ * ? < > |

And then I had some residual problems with non-standard versions of accented characters - fancy inverted commas, etc.

Most of my files became visible over smb when I deleted | (pipe), which some time ago I had used in album titles as a substitute for : (colon), which was about the only character in filenames that Mac objected to. As I was working within Mac OS, I had created filenames automatically, using Yate to compile them straight from Tracknumber, Work and Track Titles. And afp was happy to deliver these as they stood to Audirvana, JRiver etc; and Minimserver/BubbleUPNP has no problems with them.

I used FileRenamer4 to search and replace the errant characters. My music folder via smb then showed (in Finder) the same number of folders and files and storage volume as via afp. The totals for albums/tracks shown in Roon now tallies with my total number of albums and tracks shown by other software, although I expect there may still be some lurking problems.

And I’m thrilled to find how easy it was to edit out Kylie Minogue as an identification…