Hard drive vanished

Roon Core Machine

ROCK running on I7 3770, 16gb RAM

Networking Gear & Setup Details

SKY gigabit router - ethernet - ROCK machine - raspberry pi

Connected Audio Devices

output to raspberry pi running ropieee

Number of Tracks in Library

60000

Description of Issue

Internal hard drive has vanished for the 2nd time in a week. Tried to play music via app and progress bar just sits at zero, rebooted ROCK and hard drive gone!

1st time I had to remove it from ROCK machine and reformat in a caddy to reinstall into ROCK before it was found again.

Hard drive is only 9 months old and has only been used for this purpose - system was working fine until a week ago. 1st time was before the update to 2.

Anybody came across this?

Aha, I have similar problem in that I can’t finish a ROCK install if the internal drive is attached.

My machine ran perfectly for at least a year. It ran perfectly with the original V2.0 install, but when I had to recover from the Roon driven mistaken downgrade to V1.8 then the problems started.

I think that there is a common cause to these problems.

It has been suggested to me by @danny to reformat the drive in another machine, but it seems that doesn’t work very long.

Them flipping hard drive fairies are at it again.

Have you got any more details of your ROCK device? Make and model

hp compaq elite 8300 i7. My old PC as I said running absolutely fine until this week. I wouldn’t mind if I could get it up and running in less than 24 hours - 3tb transfer of music.

I don’t have any local stored music, so I don’t know if this would work. Doe’s Roon recognise a HDD in a caddy via USB?

Or in a caddy via USB on a router as a shared drive.

No it wouldn’t see that either. Does the file system of the drive matter before it’s connected to ROCK? Can’t remember any problems when I first set this up.

Do you mean you have tried this?

https://help.roonlabs.com/portal/en/kb/articles/rock-storage-basics#:~:text=We%20recommend%20USB%20drives%20connected,EXT4%20if%20you%20don’t.

I would have used that for initial setup. I formatted the drive NTFS anyway so should still have been recognized. Windows also claims no problems/errors with drive, if that can be trusted.

This happening once is a nuisance but twice is a bit worrying considering I played music for about 10 mins in between the drive going awol.

When it went AWOL, was this after rebooting your Core?

Inside your Core, can the HDD be plugged into another SATA port. I think hp compaq elite 8300 i7 has 4.

I was trying to play music that was showing in my library but progress bar just sat at zero then skipped to next song and repeated the process - I think the drive was already awol by this point. Only then did I reboot to find an empty library and drive gone. Last copied music to the drive yesterday, only thing I did different was hibernate my windows PC. Surely that could not affect CORE on a seperate PC?

Since you’ve installed ROCK on this machine, rather than an Intel NUC, you have what is referred to as a MOCK.

Hopefully another forum member has a solution as I don’t believe Roon support with get involved.

I’ve move the thread to the Tinkering section of the forum where you may get more help with a MOCK device.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.