Haunted Roon (core downgraded itself to 1.8 overnight)

Roon Core Machine

NUC8i5BEH (Core i5)

Networking Gear & Setup Details

Ethernet (EdgeOS router)

Connected Audio Devices

NAD C338, HiFiBerry. WiFi (Netgear WAC540 access point)

Number of Tracks in Library


Description of Issue

I upgraded to 2.0 shortly after it came out. I had one legacy client that couldn’t run 2.0, so I followed the instructions for 1.8 compatibility (create Roon directory, copy roon_18 into it, rename to roon). That and my other five 2.0 clients (1 Mac, 3 Android, 1 Windows) all worked fine. Until today. Today I wake up and the core had downgraded itself to 1.8 and none of my 2.0 clients could connect. Since nothing can connetc, I can’t access Settings. They correctly identified the core as 1.8, latest versino, and said “update required”. I thought that maybe the legacy client was confusing things so I uninstalled it and restarted the server. No luck. There is no option to upgrade anywhere.

Is there any fix? Or do I just have to do a clean reinstall from a USB device?

You need to decide first whether you want 2.0 or 1.8 legacy. All your devices need to be on the same version.

If you have a single device that is incompatible and for which you want to use 1.8 legacy, then all devices need to go to 1.8 legacy.

You followed the instructions to downgrade your Roon core from Roon 2.0 to Roon 1.8 Legacy. Now, you need to downgrade all of your Roon clients to Roon 1.8 Legacy. Check the Google Play store for Roon Remote 1.8 (Legacy) for all your Android devices. Then, you can deal with downgrading your Mac and Windows PC.

Of course, you could put your Roon core back on Roon 2.0 and just not use the one device that is not capable of running Roon 2.0. Do you really need 5 or 6 Roon clients?

You also can’t use the new Roon ARC mobile app with Roon 1.8 Legacy. Roon ARC requires your Roon core to be on Roon 2.0.

I want 2.0. I installed it when it came out. The downgrade happened by itself from one day to the next.

Well, no. I followed the instructions for 1.8 compatibility for 2.0. All of my clients except one are 2.0 and had been working fine. 2.0 had been running fine until last week when my core downgraded itself.

There is no 1.8 compatibility for 2.0. You have to run Roon 2.0 or Roon 1.8 Legacy. The instructions you followed and posted above are for installing Roon 1.8 Legacy. So, you can stay there or install Roon 2.0. It’s your decision. However, all clients and core need to be on the same version.

that’s very interesting since the old 1.8 client and my 2.0 clients worked until last week. i’ll just delete the old 1.8 client and reinstall 2.0.

1 Like

You also need to upgrade your Roon core back to Roon 2.0.

yup. got that.

1 Like

ah. just to state what everybody else knew, what i thought were compatibility instructions were downgrade instructions. (duh). happily running on 2.0 now. thanks!


So now, you can try to figure out Roon ARC.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.