Have trouble getting the Ropieee display working

In Roon settings you enable the zone and name it and you also enable the ropieee extension. There is no display to enable in roon extensions just the ropieee extension.

In ropieee webpage if you have the display tab you set the orientation if needed and name it the same as the zone you enabled in roon. If you dont have the display tab then you need to reflash.

I would sort out the power issue before trying a reflash. There are two connections for power needed when running the display. 5 volt 2 amp power brick works for mine.

It looks like you already enabled the extension, according to your screenshot.

Given that nothing is displayed at this point, and you have confirmed that “Den” is spelled the same (no spaces etc), and you have confirmed your power source, I would try the following:

  1. Reboot your Core and endpoints.
  2. If that doesn’t work, try re-flashing.
  3. If that doesn’t work, submit feedback (from the Advanced tab in the web page) and tag @spockfish with the identifier.

@Nathan_Wilkes @wizardofoz @bearFNF and others:

I really appreciate the assistance. Here’s where things stand now based on your suggestions:

  1. The problem is that the 7" display screen stays in text mode, displaying the Linux console. It never switches into graphical mode (if indeed there is a mode change). The last line on the display is “RoPieee is RUNNING”
  2. I’ve rebooted the RPi with two power supplies so the lightning bolt is gone. I thought I could power the display and the RPi with a single 5V 2.5 amp supply, but apparently that is not the case.
  3. The audio zone that I want displayed is a pair of LS-50Ws. The name of the zone is “Den”. The same name is used in the RoPieee net interface in the Display Tab.
  4. I’ve rebooted the Core, the speakers, and the RPi.
  5. Apparently I have enabled the RoPieee extension. It says “RoPieee Remote Control V2”; I was expecting it to say something like “RoPieee Display”, but if that’s the correct thing, then I do have it enabled.
  6. So the only thing to do before reaching out to @spockfish is to reflash the RPi and start over. I’ll do that this evening and then try again.

Again, thanks for the assistance.

-Steve

One thing I forgot to mention is to be sure to format the SD card first before flashing. Let us know how you fare tonight.

Nathan

This is what will display for the extension…so you are good. Reflash…and maybe have both your powersupplies connected when you install. 3.5A adapter should be OK

14

I will re-flash tonight and update here. Out of curiosity, can anyone tell me what happens on the display after it says: “RoPieee is RUNNING”? Does it then immediately switch to a graphical display? What happens if you’ve mis-named the zone name? Does it still switch into graphical mode? I’m just wondering what the experience is, when it’s working correctly, after you see “RoPieee is RUNNING” on the Linux console (which is being displayed on the 7" display).

Thanks!

You should get a black album area and play controls…until it goes to sleep with the time displayed if you have that set in settings…lower left corner to access the settings for brightness etc

Thanks. I hope re-flashing with two power supplies addresses the problem. And I just ordered a 5V 3.5 amp supply.

Yes to both. At a minimum you should see either an error message or blank album art with normal controls.

I found that turning down the screen brightness helped ensure that I had no power issues. You might experiment with this setting as you sort out the other issues.

How do I turn down the screen brightness if I can’t get into the graphical part of the display? I know once you get things working, there are some settings, including brightness, that you can adjust on the touchscreen. But I can’t get that far.

Or is this a recommendation for once I get it working?

Sorry, yes, a recommendation for when it is working for you.

1 Like

I’m happy to tell everyone that my RoPieee display is working. Re-flashing the SD card and booting with two power supplies fixed the problem. The display immediately went into graphics mode and started working as soon as I set the correct zone name in the settings.

Thanks to everyone who helped me out! I truly appreciate everyone’s assistance.

Steve

4 Likes

I don’t want to open a new topic.
I have same problem.

I use ropieee more one year today I want to connect screen. There isn’t displat menu on ropieee web gui, there is anything on roon display, there is remote control but it isn’t about lcd it’s called only “ropieee” on extensions.
I have an display but it is different brand.
When first running ropieee, display must be connect? Or it doesn’t matter?

Hello @onkal,

The display software only installs upon initial installation of RoPieee, and of course only the Raspberry Pi 7” display is supported. A quick re-flash is the easiest path forward.

2 Likes

Thank you, I will reinstall.

Hello @Nathan_Wilkes,

I reinstalled but display doesnt work. :frowning:
Roon supports only Pi 7” display? I have waveshare 5" display because 7" display is very big for my player box.
Isn’t there another way for it works?

Using RoPieee, no, as it only supports the 7” official display.

There are people in the forum who have setup a kiosk mode on a custom Linux install, which might work in your use case. Or, it may be possible to use the native Roon http publishing mechanism, using a web browser on your Pi. Either way, it means a solution other than RoPieee.

Thank you Nathan.

I research now.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.