Having issues logging into Roon Core after a month away

Roon Core Machine

ROCK running on Intel NUC 7i78NH, 8GB RAM

Networking Gear & Setup Details

Cox Panoramic WiFi modem/router with a Linksys SE3008V2
DS 216j NAS with dual 4GB drives

Roon Optimized Core Kit Roon OS 1.0 (Build 227) Stable
Version 1.8 )Build 1021) Stable

Connected Audio Devices

PS Audio Direct Stream Digital DAC with ethernet bridge
Ethernet over power lines via TD-Link AV-2000
Remotes are iphone, iMacs and a Windows Surface running Win 10x

Number of Tracks in Library

40,000 tracks

Description of Issue

I am caught in a vicious circle. My Roon server comes up with “Un oh, something’s not right. Make sure your Roon core is turned on and that you’re connected to the same network. Select a different core.”
When I select a different core it gives the standard “…you won’t be able to access the music you had before.” It then shows me the Roon Optimized Core Kit on my network and says “ready.” When I select “Connect” It says “Waiting for your Roon Core.” and then it goes back to “Uh oh…” Las night, it was included the “Are you Online” screen as well.

So, I am unable to even begin to restore a backup.

All of this was proceeded by some odd behavior after I returned from a month-long trip during which I shut down all my systems. I’d never seen the “Waiting for your Roon core” wheel until this past week. I attempted to make a backup but Roon wouldn’t allow it (but I forget now the prompt). And I had to reboot my Intel NUC multiple times a day.

Guys, software is supposed to become MORE reliable as it matures. Roon is not doing that. Every time I travel I have problems when I return home.

Thank you!


Did you try Restarting the Server from ROCK’s Web GUI?

Roon generally advises against using such devices - read this Roon article.
It may have worked seemingly flawless for you and others, but it’s not guaranteed to stay that way.

Crossing fingers you’ll get it resolved…

I don’t know if this will help, but try changing the DNS server. It’s a bit difficult to make out, but it looks like you’re using Try changing this to (Cloudflare DNS) or (Google DNS).

Agreed, before I installed wired ethernet to my server, I found that MoCA was superior in reliability and speed EoP.

Thanks for the suggestion. I noticed the DNS server, too, and it certainly would seem a likely issue. But I tried to change it without success. Can anyone suggest how to do it, please?

I think you need to set a static IP address before you can change the DNS settings. Take a look at this KB article for further details.

Alternatively, as you’re currently using DCHP, try changing the DNS on your router instead. This would set the DNS for your whole network to either or (or anything else you choose).

1 Like

Thanks, Kal, a good suggestion.

Yes, many times. ROCK itself seems to run fine. I also renamed RoonServer to RoonServer_old and tried recreating the database, but that had no effect that I could discern.

I’ve rebooted everything (modem/router, switch, NAS, NUC) multiple times with no apparent change.

Ok, you are having trouble with the Control functionality of the Roon package on your PC. Did you try reinstalling the complete package?

Thanks, DaveN! Changing the DNS to did the trick!

1 Like

Excellent. Did you change it on your router or just on the ROCK?

Just the ROCK.

You might find that (or speeds things up across your network, if you change the DNS or your router, but if everything’s now working as expected it’s not essential.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.