Having issues with Oppo HDMI

I have a Oppo BDP-105 connected to my Mac Mini i5 by a HDMI v1.4 cable but I get a sound full of crackles every time I send a PCM audio greater than 96k, whereas the BDP105 accepts sample rates up to 192k. There’s no fix for that?
Thanks in advance.

HDMI cables can be very flaky if not up to spec.

Maybe try a different HDMI cable?

Hi! I’ve tried with two of them. The one that comes with Oppo and the Eagle HDW360 from Absolute Acoustics. Both show the same result.

Ok, did you check to see if Device Setup for the Oppo looks the way you think it should?

In the Advance Setup, what is the Max Sample Rate for PCM?

If the Max Sample Rate for PCM is set to 96K, everything goes fine because all the content is limited or downsampled (if so) to this sample rate. However, if the Max Sample Rate for PCM is set to 192K, there’ll be two possibilities: if the content’s sample rate is lower or equal to 96K, everything will be fine too, but if the content is high sampled, the crackling appears.

Ok, gotcha.

Give me a moment to experiment with one of my endpoints.

It’s been a long time since I’ve used a Mini as Core, so I don’t remember much, but isn’t there a Sound Menu in macOS?

Also, when the crackling source happens what does Signal Path look like?

I tested with an endpoint that uses an iFi DAC and 196K worked as expected, of course.

I’m trying to play a DSD 64 5.0 file, so the Signal Path shows the same for both: High Quality. The only thing that changes is the final sampling rate depending on what is set to Max Sample Rate.

Aha, this only occurs when you’re using DSD source?

I didn’t see that in your original problem description.

I thought it wasn’t an issue. All my multichannel files are FLAC 96k or DSD 64, so when a DSD 64 file is downsampled the result is a PCM 176k stream, higher than the 96k limit. I’ll check with a 192k multichannel file…

Hi @Joao_Lins,

You can try a 192 multichannel file as a test from the 2L test bench (http://www.2l.no/hires/index.html). I would also verify if the same issue occurs outside of Roon when you set HDMI as your output device. Does this issue occur with regular stereo tracks or is it just multichannel that’s affected by this?

– Noris

1 Like

@noris -

It sticks in my head that some DACs can’t handle a 176K input.

Is this true or am I mis-remembering?

Hi, @noris! Thanks for your time. There’s no 5.1 192K files there, only 2ch 192K or 5.1ch 96K. I’ll try to produce one from stereo files and let you know. There’s no problem when I send 2ch 192K/24bits files.

EDIT: I’ve found out that the problem also occurs with stereo 192K/24bits files. It’s weird because I know that it worked some time ago with a previous Roon version. So I’ve tested with Foobar2000 and all the files (2ch or mch) work flawlessly.

Hello @Joao_Lins,

Thanks for confirming with 192/24. Hmm, can you post a screenshot of your Signal Path while there is 192kHz content playing to that HDMI zone?

What does your Device Setup look like for the HDMI output? You can access this info by going to Roon Settings -> Audio -> Cogwheel icon next to HDMI zone -> Device Setup.

Please post a screenshot of both the general & advanced settings. You can use these instructions to upload screenshots to this Community website.

Is the HDMI volume set to max in the OSX audio mixer? I think I vaguely recall a similar thread where the client didn’t have the OSX HDMI volume set to 100% so this may be worth checking as well.


What year MAcMini i5 is this?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.