Having problem with thunderbolt Lynx Hilo


I have a Lynx Hilo dac with thunderbolt interface, i found Roon has problem to detect it as 16 channels dac. Audio device screen shows it has only 2 channels and the selection is disabled, I cannot choose 7.1 channel output. Understand Roon only supports 7.1 channels at the moment which is enough for my use, but now it only shows as 2 channels which renders it as unusable for my case, i use Roon convolution DSP as digital crossover.

I previous had a Lynx Hilo with USB interface which has 8 channels, Roon can detect it fine as 8 channel dac and I was able to select 7.1 channel output under audio setup. Now with thunderbolt card of the same dac, Roon only display it as 2 channels. BTW, other software like JRiver on the same core server can work as 7.1 channel with either thunderbolt or USB interface of Lynx Hilo.

Could Roon Support please look into the issue please?

I use Mac OSX 10.11 as Roon Core (Build 298)


Thank you for the report @Kevin_Tsang, the feedback and insight are both appreciated!

Moving forward, we are going to do some research into the Hilo to better understand the capabilities of the device, furthermore I have also enabled diagnostics on your account to help with our evaluation of this behavior you are reporting. What this action will do is the next time Roon is active on your core machine a diagnostics report will automatically be generated/uploaded directly to our servers. I will confirm when the report has been received so you know we have it.

Your patience is very appreciated!

Hi Eric,
I am still waiting your confirmation that the diagnostic report has been sent to you fine?

Hi @Kevin_Tsang ---- Sorry for the delayed response.

Confirming we have indeed received the mentioned diagnostics report which is now with our tech team who will be conducting the evaluation of the report. Once the team has provided some feedback I will be sure to reach back out with their thoughts/findings asap. You patience is very appreciated!


Hi @Kevin_Tsang ---- Thank you again for your patience while our techs have been looking into this behavior.

Continuing forward, our tech team has mentioned that in the Roon logs attached to the received diagnostics report that the device is reporting that it is capable up to 8 channels and in light of this the team has asked if you could please provide screenshots of…

  • The “audio” tab in Roon.

  • The “device setup” window for the zone you are using with the Hilo.

    • Please be sure to provide complete screenshots of the “general”, “playback”, and “zone grouping” tabs :+1:

-Please also try disabling “exclusive mode” and verify if this action triggers a change in behavior.


Since i have swapped in and out between USB and Thunderbolt card, i am not sure if the report you are looking at was captured with USB or Thunderbolt card. With Thunderbolt, the channel count is clearly 2 channel only and the channel layout button is disabled.

Switch on and off exclusive mode doesn’t make any difference.

Screen shots attached for further investigation:

I have the lynx hilo with usb and it was only recognized when directly connected to my pc via usb as a roon endpoint. My goal was to remove the pc from the chain and the only way to do that with my lynx was to go to optical with a converter. I was only trying to do 2 channels. I was also using a microrendu which didn’t recognize the lynx properly. I know your application is different and it certainly is confusing that it worked one way and not with the thunderbolt. My experience with roon is the dac has to be recognized properly in order for it to function.

Hello @Kevin_Tsang,

Could you provide me a screenshot of the “Audio MIDI Setup.app” on your Mac with the Lynx Hilo plugged in using first USB and then Thunderbolt? You can find the application on your Mac in the utilities folder that resides in your main applications folder. Under the “format” menu, it should show all of the possible bit rate, sample rate, and channel configuration options the device is reporting to the operating system.


1 Like

See attached screenshots, one for USB, one for TB.


When connected over thunderbolt, what is shown in the dropdown menu that says “1: Play 1”?

When you click the “Format” dropdown menu, does it give you options to select different channel, bit depth, and sample rate configurations?


Only can change sample rate, but not channel count, bit depth etc.
The dropdown “1:Play 1” doesn’t have anything useful neither.


When you click on the “Configure Speakers…” button in the bottom right of the window, is there a drop down menu labeled "Configuration: "? What options does it give you?


Under Configure Speakers, there is a screen for mapping channel like below. Even it is configured as 7.1, Roon can only see 2.0 channel.


Can you try creating an aggregate device and mapping your streams to your desired setup? To do this, click the plus button on the bottom left of the “Audio Devices” page. When you add the Lynx Hilo to the aggregate device, you should be able to go to the configure speakers tab and map out the channels to correspond with your device. This “aggregate device” should show up as an output in Roon.


Aggregate device had been tried but no help at all. Speaker configuration has no effect for Roon. Roon channel count is disabled.
As i mentioned before, Jriver on the same OSX platform and thunderbolt hardware has no issue whatsoever, it is quite obvious there are something not correctly implemented within Roon’s OSX core audio stack. I also have a bootcamp Windows, Roon ASIO also has no issue to work with Thunderbolt Lynx Hilo. The only issue is with Roon OSX core audio.

Hello @Kevin_Tsang,

Just an update, the Q&A team is currently looking into this issue and they’ve encountered some inconsistencies with our multichannel detection on MacOS. I hope to have an update for you later this week after our engineers have had a chance to look over our test cases and look over our audio driver detection code.


Any update about this issue?

Hello @Kevin_Tsang,

The engineering team is aware of the issue and was able to reproduce the behavior you are seeing. Unfortunately, while they investigate the cause of the behavior and work on a fix, I am unable to provide you a timeline on which to expect the fix to be rolled into a release. When dealing with such sensitive issues as the core OS audio stack, modifications to our codebase must pass extensive Q&A testing before they are certified for a public release. What I can say is that the issue is absolutely on our radar and we hope to have a solution sooner rather than later.


This bug still exists in the latest Roon 1.5 Built 323!

Multichannel detection on MacOS is still not working. I would like to follow-up if the issue is still being followed-up?