Having problems copying files to i5 CDR from computer

I just got my new i5 CDR yesterday.
I tried to copy some of my music files from a USB external drive using my MacBook Pro to the hard drive in my i5CDR.
When I tried to copy a folder over it gives me an error saying it needs space for the same size of the folder.
When I checked the size of the i5 CDR hard drive (which should be 10TB) it tells the amount of the spaced used by couple of CD previously ripped but it also show that as the size of the drive so I think the MacBook thinks it is full.
I thought it could be a Mac thing so I tried with a Windows PC but had the same result. I tried with the USB hard drive formatted as Apple OS Journaled and also with a USB drive formatted as FAT32 with the same results.
Any idea what could be happening?

Maybe @agillis from SGC could help?

I already email him. Thanks!:+1:

Andrew connected to my system today and fixed the problem. Both the ripping and the drag/drop were related. The problem was that the storage was not directed to the hard drive that’s why was running out of space.
Now I am ripping away my CD library.