Having problems getting Roon working [SOLVED]


I am using Roon 1.2 to run a networked setup consisting of a NAS (running WHS 2011) with Roon Core (along with JRiver and LMS) on a SSD. With Whitebear (a renderer), JRiver works well (and it has consistently been working for several weeks – without any issues).

Unfortunately, I am unable to get Roon to operate either of my two Logitech Transporters. Roon does seem to have obtained access to my music via JRiver. Roon is also “talking well” between my NAS and two wireless devices (iPhone and iPad). The NAS and the two Transporters are ethernet-connected directly to the router (Apple Time Capsule).

The NAS is a 64 bit system, powered by an Intel i7-4790K Quad-Core 4.0 GHz LGA 1150 88W Desktop Processor (16 GB Memory) mounted on a Asus H97M-E/CSM LGA 1150 motherboard. All music is stored on a single Seagate ST8000NE0001 hard drive.

There are about 30K tracks in this collection, although Roon claims there are 61K tracks (I think there are a lot of duplicates). The tracks are wav formatted – I used dBPoweramp to rip them from CDs.

When I try to play one of the Transporters, “Office (by Whitebear),” the following error message appears:
" Transport:
Playback_error_endpoint_device_init_failed "

The same thing happens when I play the other zone, “off.”

I do not get the same error messages when I try to use Airplay. However, Airplay audio doesn’t seem to work.

I made some adjustments to the Settings and managed to get an additional error message:
" Roon lost control of Audio device "
This error message was then followed by the first error message.

After things got worse (flashing screens, screen lock), I shut down the programs and re-booted the NAS. I took these shots with a phone

  1. The onboard Realtek controllers and JRiver should be disabled as they apply to only locally connected audio devices in Roon.

  2. Transporters are ethernet and as such, like all squeezebox devices, they will show up in their own section under the network section, like airplay devices do.

  3. The real question is what is preventing your transporters from being recognized by Roon as a network device.

As to #3, I’d start with the Apple Time Capsule OR a firewall of some type being the culprit. Roon runs multicast to identify and verify network connected endpoints. Several routers either have issues with this or need to have some changes in their setup to not filter such traffic. Alternatively, that traffic could also be blocked by firewalls, so you want to make sure you either add the appropriate exceptions or turn them off.

You have enabled squeezebox support in setup?


Thanks, John, Forgot that one, LOL.


I also checked my firewall settings for the NAS – the firewall is off.

Roon lost control of audio deceive usually means some other program has “control” of the output.
However I can’t see how you could even be getting this message as from your screenshots you don’t see to have Squeezebox zones.

You don’t have Logitech media server running somewhere else (anywhere e.g. NAS ) in the house? This has to be turned off.


Thanks for the quick response.

Squeezebox support is enabled in Setup.

The Windows firewall is off. I don’t have any other firewall setup that I know of.

Do you have any suggestions about how to find out if Apple Time Capsule is a culprit. I have tried resetting it but the flashing Setting screen problem persists (with the Roon loading popup indicating it is loading while the screens shift from “connected to this PC and Networked” to “Networked.”

One additional bit of info that might be helpful is that the two transporters (and the NAS) have been assigned static IP addresses. Since there is no issue with finding the NAS, I have been assuming that the Transporter’s static IP addresses would not be an issue.

Sorry about the brief delay in getting back to you. I did turn off the LMS on the NAS and the Squeezebox showed on the setting screen. “Roon” showed up on the Transporter. When I turned on the receiver, my ears exploded with music.

I know the ringing will go away soon. What great sound quality!!

I tried this on the second Transporter similar results.

Thanks for the help.

1 Like

You might check that all network components are on the same subnet ( ie. like 192.168.0.xxx). If somehow, your DHCP’d network components and the static ones were on different subnets that would be an issue. Roon operates only in a single subnet.

Nevermind as it seems you have found the issue. Now to enjoy the music! :smiley:

Thanks again for the help.

I can’t wait to check out some of the music I have with this.

I upgraded from LMS to JRiver a short while ago and was amazed at the difference. I am looking forward to “getting used to this.”