Having problems with ARC

Roon Core Machine

QNAP server.

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I can’t seem to connect to ARC from my iPhone other than when I’m on my home network. I know this has to do with permissions on my server, but I don’t know where to start…

Please tell us:

Networking Gear & Setup Details

<!-- Your network gear (model of routers/switches), if on WiFi/Ethernet, and if you are using a VPN–>
<!-- Write below this line →

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?
<!–Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated! →
<!–Write below this line–>

1 Like
  1. My service provider is Telus;
  2. My Modem is a router is a T3200M (I don’t know who makes it for Telus);
  3. From my Modem, I feed a Unifi UDM, which then feeds a 50 port managed switch. That switch then feeds 4 more managed switches in my house (all Unifi)
  4. I have 6 access points (all Unifi)

At any given time there are 25-40 wireless devices and 30 hardwired devices.

No problem whatsoever on wifi with Roon, ever. I have about 15 Roon endpoints, and literally everything works fine all the time, except for ARC…
{
“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“64.aaa.bbb.ccc”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}
}

Oh, and ARC properly found my server, and assigned Port 55002, but it is not communicating…

Where do you see this, on the router? Because the error message in the first post seems to indicate it couldn’t

In my settings in Roon?

I’m sorry if I seem thick…

If I understand correctly, the Settings > Roon ARC page in your Roon seems to be saying that it is trying to use port 55002, but the error message you posted normally indidates that it failed:

If it actually works, the Settings > Roon ARC page looks like this normally:

and after clicking that little downward arrow on the right (under the Google Play logo) to expand the info, then it looks like this:

I would check with your ISP to find out whether you are on CGNAT or not. If you are, see if you can get off CGNAT.

Sorry, what is Cgnat?

You are correct

CG-NAT is short for “Carrier-grade Network Address Translation”. It’s tech that ISPs nowadays often use to save on (scarce) IPv4 addresses for home customers.

With CG-NAT, every customer does get an IPv4 address that is good for using the Internet (including those parts who have not yet implemented availability by the new IPv6 addresses). However, these kind of CG-NAT IPv4 addresses are virtual and cannot be used for port forwarding by individual customers (which is what ARC is trying to do).

Many ISPs are willing to give you a real IPv4 address if you ask for it.

Another possibility for your problem is that your home network is using managed switches. Depending on the management that is going on there, it might also be blocking ARC

Thank you for your help.
I am not interested in spending more time in trying to sort this out.
I will use Roon as I have been, and will simply pretend ARC doesn’t exist…

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.