Having Rock issues


I installed Roon Core on a Windows i5 laptop 5 days ago and was immediately hooked. Music storage is a on a WHS 2011 network share. The first night I tested it out things worked very good and I was thrilled. I had music going to ALL my Sonos zones at the same time and listened for hours. When manually switching tracks sometimes the first few seconds of the next track would stutter for a few seconds, but it always caught up and continued playing. Because I was using this laptop to do other other tasks, it made sense that having a dedicated, faster machine to run the Core would improve performance. Especially if the music were on internal storage vs a network share.

The next day I ordered an i7 Nuc with 8gb, 120tb M.2 SSD and 2.5" 1tb SSD for internal music storage. All these parts arrived last night, I put it all together, installed Rock and got my library loaded on the internal storage. These are the issues I’m having.

  1. Sonos - Streaming to Sonos zones from Rock appears less stable than using the slower Windows machine for the Core. If I start music and don’t touch it playback will remain acceptably stable. But if I manually change tracks or accidentally tap the track progress indicator then playback will stop. I then have to manually restart playback. I noticed that the right channel of a stereo pair of PLAY:5’s was constantly stuttering and dropping out. I separated the stereo pair and that “seemed” to help. I’ve also had Tidal tracks playing to Zone 2 give a “transport” error where playback stops and I have to manually resume. When I’m doing things around the house on weekends I like having all zones playing simultaneously. When zones are grouped in Roon, does Rock send a stream to one player and then let Sonosnet take over? If there are certain do’s and don’t when using Roon with Sonos I can certainly live with that, I just need to know what they are.

My Sonos zones:
Zone 1: PLAY:5 x 2 (were grouped as stereo)
Zone 2: PLAYBAR + SUB + PLAY:1 x 2
Zone 3: BEAM + PLAY:3 x 2
Zone 5: PLAY:5 x 1
Zone 6: PLAY:3 x 1

  1. App Connectivity - I didn’t experience any connectivity issues when using the Windows machine as the Core. My Pixel phone reliably connected and I even managed to get my Pixelbook to connect by manually entering the IP address. I was super happy when I saw the Android app worked very well on a Pixelbook as long as it’s in table mode. However, after switching the Core to Rock my Pixelbook won’t connect at all, not even if I manually enter the IP address. And the Android app on my Pixel is now unreliable. I got home tonight and had to restart Rock and restart my phone before it would connect at all. Last night my phone lost connection multiple times and I had to “tinker” with it before I got it connected again. I have some other Android tablets that I will set up this weekend, maybe I’ll have better results with those. When I can’t connect with the app on a device I can open a web browser on that device and get to the Rock setup screen using the IP address in the address bar every time.

I’d appreciate any advice you can offer as I really want Rock to work for me. If we can’t figure it out, I will get a Windows license and install that on the Nuc, but I really like the idea of a lightweight OS like Rock. It feels more like an “appliance” vs a computer when it’s so easy to use and maintain unlike a Windows machine that requires constant updates, malware/virus protection etc…

Core is running on NUC7i7DNH1 with 8gb ram, 120gb Silicone Power M.2 SSD and 2.5" 1tb Sandisk SSD for internal storage.
RockOS: Version 1.0 (build 158) stable
Roon Server: Version 1.5 (build 354) stable
Music Library ~3300 tracks consisting of FLAC and DSD, Tidal Integration.
Router is Linksys EA9500 with Nuc hardwired directly to router.
All mobile devices are connected to 5ghz network broadcast from router.
Nuc and all mobile devices are connected to same gateway, with same subnet mask

Thanks for helping.

Well, now I’m super embarrassed. Tonight after I sent this message and got my phone reconnected I haven’t had a single problem. Last night after I set Rock up and copied my library over to the internal drive I started listening immediately. The fan on the Nuc was running full blast. I think the poor performance was due to Rock still being busy populating metadata. Tonight the Nuc’s fan isn’t blasting away. So I guess disregard every thing in my previous post except the Pixelbook issue. After searching the forum I see that it’s not officially supported. But that doesn’t explain why it worked for several days prior.

when a core is importing and or analysing tracks this takes a big chunk of cpu resources and will tax any system without some basic throttling set under the library settings. This will be even more pronounced when using and streaming to multiple zones, or using DSP related options like upsampling and convolution filters.

@wizardofoz Thanks for confirming my suspicion. I’ve been listening for hours now, DSD, FLAC, Tidal to multiple zones without a single issue. Manually switching tracks is working without the stuttering. I noticed that my Oppo 203 is a supported Roon device. I plan on setting that up tomorrow. Lots to tinker with and enjoy.