Having trouble getting to DSD256

I can’t seem to get hqplayer to output DSD256 anymore. It worked once. No pops, dropouts or clicks. Played audio for about 20 minutes without problems. I quit hqplayer, came back a bit later and relaunched hqplayer, now it won’t output above DSD128.

When it was working I had no issues with any of the poly-sinc filters, even the sync-m worked ok. I had also tried using different modulators (DSD5, DSD5v2, ASDM5, DSD7, ASDM7, DSD5v2 256+fs and DSD7 256+fs) and they all were outputing DSD256.

I have not changed anything in the path from when DSD256 was working to when it’s stuck at a max of DSD128.

The NAA is on a raspi2 usb stub connect to usb regen, and then another usb stub connect to the brooklyn.

Before I started all this the dipiet version was updated and I uninstalled and then reinstalled the NAA to make sure it was on the latest version. I believe it is 4.1.1 or something.

ok, I figured out what it was… I am using v3 of hqplayer and the only way I could get SDM(DSD) to be available for selection was to set the SDM Pack to DoP and then i was able to select SDM(DSD) in the main window, but DoP as I recall reading several times in several posts only supports upto DSD128…

I found that once I selected SDM(DSD) in the main window I could then go back and disable DoP and it would stay on SDM(DSD).

I would like to upgrade to hqplayer 4 but I’m stuck on Mac OS 10.13.6 as moving up to 10.14 or higher I loose support for my graphics card which in turn I can’t use Cuda.

@jussi_laako is there a version of hqplayer 4 available for download that I could use on 10.13.6 if I purchased v4?

No, generally macOS is supported for latest and latest - 1 versions. So you should stay up to date with macOS, at least up to latest - 1.

Mac OS doesn’t support cuda on newer nVidia cards now. So 10.13.6 is it for me for a while. Hell of a run down on Mac OS lately.

10.13.x - EOL
10.14.x - apple heavily incorporates metal 2 and drops new nVidia support
10.15.x - drops all 32 bit apps
11.x.x - a complete mess…

Recent HQPlayer versions don’t support CUDA on macOS either. So I think that is pretty much history.

This is just for good. HQPlayer is these days 64-bit only anyway, on all platforms.

I don’t think so, works very nicely for me. The new Apple M1 silicon is also very nice for HQPlayer.

HQPlayer is now 10.14 minimum, but I don’t test it on older versions than 10.15 since I don’t have anything older anymore. This minimum requirement will keep moving up, because also development tools used for HQPlayer keep dropping support for older versions.

I’ve given the demo version of HQPlayer 4 for windows a try and I’m curious as to why I’m having problems with poly-sinc-lp with ASDM5EC.
Nothing else is running on the computer. HQPlayer doesn’t seem to be taking advantage of the cpu at all. I can run poly-sinc-xtr with ASDM7 with no issues, that actually utilizes more cpu usage but not dropouts.
Are the EC shapers that much more processor intense, and if they are why isn’t the cpu being utilized to it’s fullest potential?

Since your CPU has HyperThreading, 50% total load is 100% load on all physical cores.

When you have drop-outs, the CPU load figures are nonsense, because playback is on-off.

ASDM7EC is about 3x heavier than ASDM7.

It is, but not all algorithms can be algorithmically split to multiple cores. And sometimes even if they could, the cross-core communication overhead grows so much that performance would just suffer. You can certainly get around this mathematical “limitation” by adding more playback channels. If you play out for example 32 channels, you’d certainly see many processor cores much busier! :wink:

So you need to right-click on the load graph and see load of individual CPU cores.

I wonder why your CPU get’s only to 4.75 GHz under that load. It should be closer to 4.9 GHz. Do you have “High Performance” or “Ultimate Performance” power profile selected under Windows Control Panel → Power.

Turbo states by default drop when all cores are used. I bumped them all up to a 49 multiplier to get 4.9 on all cores. Power is in high performance. Never heard of ultimate performance. Still cutting out. Guess I’ll stick to xtr with asmd7, hqplayer v3.25.3 on my trusty 4790k running 10.13.6.


Yes, but usually you don’t get all cores maxed out, few cores with higher load and rest on lower. So on similar CPU I get higher clocks without overclocking, that’s why I was asking.

Looks like you have four cores sticking to 100%. Please check that you didn’t accidentally make “Multicore DSP” checked, instead of grayed in HQPlayer settings.

I got around to messing with v4 again on the i9 machine. I set Multicore to grayed and everything I tried worked. Except when Cuda was enabled. It actually is less glitchy without cuda, guess my titan x is getting old. :slightly_frowning_face:

With hyperthreading I realize the processor usage percent will be off but wouldn’t 50% represent maxed out on all the main cores. It jumps to 48% on the initial start of playback when it is quickly buffering and then it seems to throttle back once it gets going, but it is working so all good for now…

So using a number of different sources from 16 and 24 bit, 44.1 through 192 I have successfully used every filter and modulator combo @ 44.1k x256 limit.
It seems the xtr filter with ASDM7EC was the most demanding.

  1. poly-sinc-xtr-lp ASDM7EC
  • 20% CPU 71% GPU (had a few dropouts)
  • 36% CPU No Cuda (no dropouts)
  • -2s 15% CPU 7% GPU (no dropouts)
  1. poly-sinc-xtr-lp ASDM5EC
  • 19% CPU 69% GPU (had a few dropouts)
  • 34% CPU No Cuda (no dropouts)

I’m going to do some listening tomorrow and see if I can notice much difference. I’ve grown to like the xtr over the others, before I was always using the poly-sinc-shrt.

I’m currently using a Mytek Brookyn Bridge DAC and playing everything back at DSD256.

Is there a more correct modulator I should be using? — I’m assuming the 512+fs is not intended for DSD256.

Thank you Jussi for your help and for an amazing player.

1 Like

For DSD256 to an ESS Sabre based DAC (like Brooklyn) I’d start with ASDM5EC. If using ASDM7EC, set the DSD filter frequency to the lowest setting at the DAC side.