Having trouble installing Roon Nuc

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Hello, I’m trying to install Roon nuc, but having two issues that I can’t seem to resolve, my hardware is a intel NUC Model NUC10FNH with a crucial 8gb ddr4 memory and a 250gb NVMe M.2 SSD Drive, I have downloaded Roon box-linuxx64-nuc3-factoryreset.img.gz and also balenaEtcher-setup-1.7.9, when I try to flash my usb key with etcher it gives me a flash failed error every time, I have tried this many times with different usb keys and computers, when I check the keys there is a folder identity and a file Roon.tar.bz2, I thought maybe I was getting a false error so I tried to boot with it on my NUC, which it would not boot to the key, but in my bios it would not let me change to legacy boot, or I just can’t figure out how to do it, please help thanks

Could you try un-archiving the .gz file first to get the .img file - then use that in Balena?

Yes I’ve tried unzipping to file to a img file and using that file but etcher still errors out

Hi Alexander, the following should help you disable UEFI secure boot for the NUC10 prior to installing Roon: -

  1. Boot into BIOS “F2”
  2. Select “Power Tab”
  3. Select “Secondary Power Settings”
  4. Select “Sleep Type Support”
  5. Change drop down to “Legacy S3 Standby”
  6. Press “F10” Save & Exit
    ** Note: Any previous Roon install may be wiped (use for setting BIOS prior to installing Roon)** At the next restart after changing this setting, you’ll see this message: -
    WARNING! A change has been detected in the BIOS Sleep Type support setting, from to . Dynamically changing the Sleep Type support setting between Legacy S3 Standby and Modern Standby is not supported and may require reinstalling the Operating System. Would you like to continue? Enter (y) for Yes to continue, or (N) for No for reboot.
  7. Boot into BIOS “F2”
  8. Select “Boot Tab”
  9. Select “Secure Boot”
  10. Change drop Down to “Disabled”
  11. Press “F10” Save & Exit
  12. Boot into BIOS “F2”
  13. Select “Boot Tab”
  14. Select “Boot Priority” check that “Legacy Boot” is “Enabled” & “UEFI” is “Disabled”. If not select/deselect them.
  15. Press “F10” Save & Exit
  16. You should now be able to Boot from your USB & install Roon Rock.
    That’s it. Note: this works for the NUC10… but will not work for more recent models “NUC11…”
    Please follow Roon Rock installation instructions for any other required changes to the BIOS.

Hope this helps

Yes that you that worked, but the first issue is still a problem, I cannot flash the img file to usb without etcher failing

Could it be the USB stick that you’re using? I’ve just downloaded the file, used Balena Etcher with a 16GB USB stick, and it’s worked without any problem…

I’ve tried five different keys 16gb and up to 128gb, I don’t get it, I’ll try a few more keys

What are you using to unzip the file? You should end up with a Disc Image File around 409,600KB but I don’t see that in the image you posted. Have you tried using 7zip as I know that works with the roonbox install.

Ok I’ll try that one

What Windows OS are you using with Etcher?

Etcher is not always successful, for some reason. Sometimes I have to try several times before it oks the flash.

Also, sometimes after I use Etcher, the USB stick is in a state that is permanently unusable, i.e. Windows can’t even re-format it.

OTOH, I suspect some flashes are really ok, in spite of what Etcher thinks, but I have never tried out that theory.

Did you try using the supposedly failed Etcher flash?

There used to be an app called Rufus that was more consistent.

I often have trouble flashing drives with Etcher. Rufus is an alternative that does the same thing without fail. one thing to note: you need to uncompress the archive image first. Rufus - Create bootable USB drives the easy way

1 Like

Ok That was it! After taking care of the other issues, the etcher errors turned out to be false! I was able to install successfully……thanks so much!!!


Glad you got it sorted! Hope you enjoy Roon.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.