Having trouble with ARC setup

A post was split to a new topic: Port Forward 504 Unknown Error

A post was split to a new topic: Fritzbox with QNAP Core Error

Maybe, after finishing the nuclear reactor in my backyard, I’m able to set up Arc and help you with it, having exactly the same error here…


With my current ISP architecture (in Thailand), I unfortunately cannot use the Roon ARC either. Anyway it’s a good feature and I’m looking forward to solutions the Roon dev team will bring about. I understand that you are working on the ipv6 support?

In the mean time, is it possible for Roon ARC app to have a setting for us to manually enter a domain name and port for connecting back to Roon Core ourself? The ISP let me configure this kind of dns/port forwarding on its web. And I’m using this mechanism to connect back to my home camera and also to my ebook library (Calibre) successfully.


1 Like

I know how you feel, it’s frustrating beyond all things. If you can find a computer literate friend, you won’t look back.

Been through all of the help and troubleshooting, and my findings are my ISP is using NAT IP, seems to be a common thread.

I work in IT and tracing all of the settings to get this far is not easy at all. Asking people to go to into their routers advanced config and having to ask ISP’s for a private IP to get your new feature to work is pretty poor form Roon. My ISP charges $10/month for a private IP, which is an additional $120/year on top of the cost of Roon, yeah nah bro.

I’d rather not have an option than one that makes my music life feel like I’m back at work. I hope you’ve hired an extra 5 support staff for all of the support tickets you’ll get from this.

Roon ARC app deleted, Tidal app working first try.


Dear Noris,
Roon is working on my Intel NUC. Still no connection with Roon ARC. Here are my details:

  1. ISP = XS4ALL (now KPN)
  2. Router = Fritz Box 7581
  3. Additional = MESH network Netgear Orbi RBR50 (one base, one satellite)
  4. No VPN, proxy server or other security
  5. Intel NUC8i5BEH, wired to Orbi Satellite
    Hopefully you can give me some advise on this…

Kind regards,

I have the same issue. All Roon need to do is have options to enter external address and port to access Roon from outside.

Saying this, I also use Plex built-in feature, which will auto detect my current IP address, sent this information via Plex to my mobile device app. I can access all my movies from anywhere easily.

So jealous of all the people enjoying their Roon ARC outside of their houses… :pleading_face:

Hmm, Orbi RBR50

Just curious, what’s your endpoint? And where is it plugged in.

I’m wondering (though it shouldn’t matter) if mesh networks using WiFi backhaul could be also a factor to some issues.

If your Nuc is in the satellite and endpoint in main unit can you try an Ethernet backhaul by temporarily moving them to the same room.

Have you tried having both Nuc and endpoint plugged into the main Orbi unit?

Nowhere. Does not work :sob:

Have you posted for help?

I did. No reaction from support sofar…

Can you point me in the right direction of your post?

Hi @RM_Kamphuis ,

Sorry for the delay in getting back to you, things got a bit busy after release and we’re still working on catching up.

What is the exact error message that you get in the Roon Settings → ARC Tab? Can you copy and paste it here (without the IP address parts)?

Is your FritzBox in “modem only” mode? I suspect that you may have a double NAT situation here if it is. Fellow users have posted a guide for Fritzbox port forwarding here:

And there is a guide for port forwarding on Orbi here:

1 Like

Thanks Noris, I really appreciate your efforts! Just so frustrated trying to get everything on track without succes. But indeed my Orbi is steup as a router. I wil try to alter the settings today to Access Point and follow the steps as described.
I’ll let you know. Goal is to also post a picture outside using ARC :smiley:


1 Like

Champagne is popping, balloons everywhere and the big band is playing! On Roon ARC :smiley: :+1:
It took me 15 minutes and it works! Only warning on my FritzBox is now that my ROCK is an “exposed host”. Hopefully that isn’t a problem.

Thanks Noris!

1 Like

That’s amazing news @RM_Kamphuis , indeed cause for celebration! :champagne: :tada:

As long as you did port forwarding and didn’t do something called “DMZ”, you should be ok. Port forwarding is exposing your ROCK to the internet (on one port) and that’s pretty secure. If you did DMZ, that exposes the ROCK to the internet on ALL ports, which is not secure. Hopefully, you did the first choice :slight_smile: . Happy listening!

1 Like

Thanks again Noris for your support! No DMZ indeed, only the extra setting for this port so it is not covered by the Fritzbox firewall.
Without this setting and only port forwarding it did not work.

Have a nice weekend!

Kind regards,

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.