HDMI Multichannel issues on Windows [Fixed in B196]

(Eric Stewart) #21

Hi @Marco_de_Jonge and @Ulf_Jalmbrant ---- Thank you for the reports and my apologies for the troubles here.

I am not sure if you have taken a look at our KnowledgeBase yet but we have a section dedicated to setting up Multichannel playback in Roon. Give it a look and let me know if any further help or clarification is needed :sunglasses:

-Eric

#22

Having the same issue. Is anyone having any luck outputting multichannel with Roon on Windows through HDMI?

(Hans Groot Wesseldijk) #23

Hello Eric,
Sadly your advice is not very helpful.
Problems with Nuc are on systems that seem to work fine with JRiver.
So the driver seems to be working. We all tried other drivers when possible.
Channel layout is greyed out, so the rest of the instructions are out of reach!

(Brian Luczkiewicz) #24

@eric, this was actually broken stuff, not people in need of docs :slight_smile:

These issues will be fixed in the next build. Make sure that you update your core, remote (the one you use for the device setup screen), and bridge (if applicable) at that time, and let us know how it goes.

1 Like
#25

Ok fingers crossed then, please can you post on this thread when that build is released

Cheers

(Brian Luczkiewicz) #26

Absolutely.

(Marco de Jonge) #27

Thanks ! So this is both reproducible, and possible to solve at your side. That’s great news :slight_smile: !.

@brian: I won’t take your answer as a ‘promise’, but could you give a +/- ETA on when this update will be released ?
I have some 2 weeks remaining on my trial, and this is the only thing that’s keeping me from a lifetime purchase…

I’m sorry for pushing…just really excited :). I have seen how Roon handles issues like this in the meantime, and I’m really, really impressed by that ! You really earn my trust :).

(Brian Luczkiewicz) #28
#29

OK well I installed Build 196, uninstalled and reinstalled Roon Bridge on the NUC and still Channel Mapping is greyed out.

Can you please tell us what you think you fixed and what else we might have to do to get Multichannel working via Windows (10 in my case)

Thanks

(Brian Luczkiewicz) #30

Please double check you have:

  • 1.3 Build 196 on the core
  • 1.3 Build 196 on the remote if you’re using one (which means no iOS, as Apple hasn’t approved 196 yet)
  • 1.0 Build 62 on the bridge

I saw this working on a NUC 12 hours ago. It was partially a UI problem, and partially a problem related to how formats are probed on Windows, so really important that all components are up to date.

#31

Good news, its working !!!

The new app just appeared in the App Store so I downloaded, restarted the iPad, Core and Bridge and now all systems go !!

And as an added bonus my DSD to PCM conversion is working again which was a problem pre 1.3 !!

I’m all set now !!!

THANKS :slight_smile:

#32

WOW!!! This is as good as my system has ever sounded. Better than stereo. Thanks Roon.

split this topic #33

2 posts were split to a new topic: Cannot play 2.0 FLAC files that are DTS encoded

(Marco de Jonge) #35

Unfortunately, build 196 only partially resolved the 5.1 HDMI issue for me :(.

I CAN now select 5.1 as channel layout. But when I do so, I get no audio at all (both stereo AND multichannel won’t output).Consistently gives the following error :

Strange thing is : it DOES seem to work properly, when I select 7.1 as channel layout.
I have to do some routing and mapping externally for my actual 4.2 configuration, but that’s my own problem.

It would be very nice if the 5.1 layout worked as well, as that better resembles my actual configuration.
Does anybody @support have suggestions for troubleshooting ?
Other applications have no problem at all outputting 5.1, so a configuration problem seems unlikely to me…

(Intel Nuc6i5SYH WIN10 64bit + Full Roon, HMDI out, straight into Marantz AV receiver. That’s all).

(Hans Groot Wesseldijk) #36

Hello Marco,

In my case everything works as expected.
I can set 5.1 and 7.1 for my 9.1 Pioneer receiver that actually is set up as 7.1.
When i choose 5.1 in audio setup in Roon i hear surround channels from my back speakers.
When i choose 7.1 i hear surround channels from my side speakers.
The source files are 5.1 flacs.
All according the way i have mapped my speakers.
I’m a happy Rooner surrounded by music and utter satisfaction. Kudos to Roon technicians for their fast response to our disapointed reactions…!

(Marco de Jonge) #37

Hi and thx Hans :slight_smile: !
Absolutely, big big Kudo’s to the Roon team. Exceptional software and support !
And no, I’m not at all disappointed. Bugs just happen when big changes are made, and are no problem if they’re properly dealt with.

I think I’ve narrowed down this issue a bit (the playback_error_endpoint_device_init_failed).
This problem only appears when I try to play 44.1kHz content without upsampling, both stereo and MCH.
If I let Roon do its upsampling magic, there is no problem at all. No errors, and audio is OK.
But I prefer not to resample…

Any other sample rate, even when not upsampled, works OK as well. Just 44.1kHz without resampling, fails.
My PC and receiver are obviously capable of playing 44.1kHz content; for instance JRiver plays it fine and shows no resampling.

Apparently, changing channel layout from 5.1 to 7.1 is an alternative solution for me, even without resampling.
It baffles my why this is working, but I know it does. Can reproduce it every single time.

Anyway, I now have 2 or 3 satisfactory workarounds (upsample, setup as 7.1 or use JRiver emulated driver).
Don’t see any need for Roon to treat this as ‘top priority’.
But for the near future, I’d be very interested to know why it doesn’t output any 44.1kHz in my setup, when configured as 5.1… !

(Brian Luczkiewicz) #38

When Roon first talks to the driver, it asks if the 5.1 layout will be supported. The driver says “yes” so we present the option. The error you’re getting later suggests that when we ask the driver to take the 6ch stream, it says “no”.

I think the right way to run with this setup is to just leave it in the 7.1 mapping. Any situation with HDMI is going to have a decoder/avr downstream that understands what the channels mean and how to route them to speakers–which is why 7.1 mode works for you.

I’m not the authority on JRiver, but I think they handle this stuff a bit differently (i.e. their 5.1 mapping may be sending 8 channels all the time and just leaving the last two blank–whereas our 5.1 mapping actually causes us to address the device in 6ch mode). I could be wrong–just thought I remembered seeing that someplace.

The good news is–I have the same NUC and a Marantz SR6009 here, so there’s a good chance that I can get the same behavior you’re seeing. I’ve made a note to look into this when things are a little bit less busy in case there’s something we’re doing wrong. IIRC when I tried that setup out, I also got the right behavior in 7.1 mode.

(Marco de Jonge) #39

Nice, and thanks already !

Your hypothesis makes sense. But : my receiver (NR1504) can only _out_put 6 (5.1) channels, and no more.
Would be very very strange, if it needed 8 (7.1) _in_put channels for that. But you never know… :).

I do agree : setting layout as 7.1 just works right now, and routing/mapping is not a problem at all.
I just find it strange that I can NOT feed your 5.1 output, into my 5.1 receiver.

(Brian Luczkiewicz) #40

It probably has more to do with the HDMI driver on the NUC than the receiver.

(Marco de Jonge) #41

Allow me to revisit an older thread. Intended just for the information of the development team; I’m not searching for solutions, really !

[quote=“brian, post:40, topic:19334, full:true”]
It probably has more to do with the [windows] HDMI driver on the NUC than the receiver.
[/quote]If this is true, then the Linux ALSA driver has almost exactly the same flaw…
I moved to the linux-based ROCK the day it came out, and experienced almost the same :

  1. In WIN : only 44.1 kHz content wouldn’t play, when output was configured as 5.1.
    In LINUX : no sample rate at all, will play this way.
  2. In WIN : upsampling to any other sample rate, would magically solve that.
    In LINUX : upsampling doesn’t solve it.
  3. Error messages are the same as above, for WIN or LINUX.
  4. Configuring as 7.1, even when you have no 7.1 capable system, works perfectly in both WIN and LINUX.

Again : I’m not looking for solutions, just informing. It might save a couple of support issues, if you ever found the cause of this. (And OK, have to be honest : I cannot stand it, when I don’t understand strange computer behaviour like this :smile: :blush:)

Loving ROCK by the way ! Smooth migration, snappy system. Can’t thank you enough for that !