HDMI output not working

Roon Core Machine

Original Nucleus.

Networking Gear & Setup Details

Connected Audio Devices

USB to Emotiva RMC-1L.

Number of Tracks in Library

Description of Issue

Roon Nucleus HDMI is dead.

USB output works. HDMI output is dead. Stopped working after last fw update. Tried reset with no help.

USB output goes to Emotiva RMC-1L. Zone shows up. If I play music the progress line goes across song, but no sound.

I think the Nucleus has gone bad. HDMI has always been trouble, but a reset of the Nucleus usually fixed. Now nothing.

Is this a problem with your new fw or is my unit broken? And if it’s broken, how do I send in for repair? Or do you have an upgrade deal to newer Nucleus?

I will try trouble shooting, but I’ve restarted Nucleus by power button numerous times. Re-powered the Emotiva processor. Checked device settings for that zone.

Pretty sure the HDMI on this Nucleus is bad.

Can you connect a monitor or tv to the HDMI output of the nucleus and see what it displays ( if anything) on a reboot of the nucleus.
That will be a start to troubleshoot this.

1 Like

Thanks for getting back so quickly. I had a couple glasses of wine with dinner before I saw your post. I’ll try this tomorrow.
assuming the little box of writing shows up in the top corner, is there something in particular you want to know?

Well if you could post a screenshot of whatever you see on the screen when rebooting that would be great.

2 Likes

I cannot post what is showing on my TV, but saved screen captures from my laptop which is used as my remote.




The second to last last screenshot list what is on my TV, but in a different order.
Today I got it to work for a short time. It played using HDMI out from Nucleus to HDMI in on Emotiva RMC-1L
I was playing Dianna Krall The ‘girl in the other room’ dsf stereo file and it played fine. I tried playing the 5.1 dsf file of the same album and it played, but only played the 2.0 version. Signal path is on last screenshot.

There is no reason for the down-mix.
Just tried again and no audio. HDMI out from Nucleus is hit and miss, and not working correctly for multi-channel files.

Am I missing a setting? Does it not work correctly if both usb and hdmi are connected? Or is the Nucleus bad?

When it’s not possible to get a screen capture, take a photograph of the screen (say with a smartphone) and then post that image.

1 Like

As I said, the info that was on the screen is the same that was in the third screen shot. Just in a different order.

That seems to be a handshake problem, which occures after updating the core.
What I would do: Power off all items and disconnect the hdmi cable.
Start your Emotiva Pre after connecting the HDMI cable. After that start your Roon core snd show your audio settings for this endpoint.

I believe you are right that it is a handshake problem. Followed your instructions, but it didn’t work. Turned on my TV to see what was on the screen. When I changed the TV’s input to the one connected to the processor the sound came on.
Audio path is: Nucleus HDMI out > Emo Processor HDMI in > Emo HDMI/ARC out > TV HDMI/ARC in.
Switching the EMO HDMI out to non-ARC output did nothing.
Then went into the Nucleus setup and I see there is a new ARC setting. I had opened it a few days ago before when trying to troubleshoot this problem and it apparently tried to connect and timed out. Thought nothing of it. I opened it just now and again it timed out. I looked for a way to turn Roon ARC off or disable it. Apparently who ever set this up didn’t think that maybe some people don’t want or need this feature. It seems like its forced on.

So, Roon @support - since this problem seemed to have started after your latest fw update that added Roon ARC, how do I disable Roon ARC? This should be able to be tuned on/off by users, not forced.
I don’t know if Roon ARC is the culprit to this problem, but I would like to be able to switch it off to see if it is the problem.

Or can I revert to a fw prior to Roon ARC?

Hey @Thomas_Giloy,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

You will only see the wheel spinning when you open that Settings Page (Roon → Settings → ARC). If you haven’t set up ARC or aren’t using it, it will still send out a port test when you access that tab, because it’s initiating a diagnostic test to see whether your network can port forward. It doesn’t take up any RAM or space and it doesn’t interfere with anything :slightly_smiling_face:

Let me know if you have any additional questions, and if you’re still running into issues here :+1: