HDMI output won't get enabled on ROCK

I just installed ROCK on a NUC7i3BNK, after having its BIOS updated to v69.

I would like to use the NUC as a core and as a bridge, using its HDMI port connected to my amplifier.

The problem is that I cannot enable the NUC HDMI output (it keeps “enabling…” but it never completes):

I tried all the adapters (HDA Intel PCH HDMI 0, 1 and 2 as well as HDA Intel ALC283 Analog), none works.

So I decided to install Roon on top of Ubuntu 18.10 server on the same computer. I installed roon server and it worked instantly:

NB: The multichannel speaker mapping is correct. (Hurray!)

So I guess I’ll stick with Ubuntu for now but that is weird, am I the only one with this problem?


I’m using ROC on a NUC7i5BNH and it works fine. Like you have under Ubantu; the NUC used HDMI 0. One thing I found was that my pre-pro needs to be on for the port to enable. I think when the port is enabling it is sending HDMI handshakes and it needs to see a receiver in order to enable.

One difference with ROC and Ubantu might be the codec installation. Did you do the codec install step with ROC?

Good Luck

Did you do the codec install step with ROC?

Yes, I had ffmpeg up&running.