HDMI playback issue [Resolved] with MacOS midi audio settings

Roon Core Machine

MacBook Pro, mid-2014, running OS 11.6.8

Networking Gear & Setup Details

MBP connected to NAD 758v3 via HDMI, also on gigabit Ethernet

Connected Audio Devices

NAD T758v3 via HDMI (for multichannel) gigabit Ethernet, gigabit Ethernet to a RoPiee raspberry pi in another room.

Number of Tracks in Library

38,000

Description of Issue

Been struggling for 2 weeks to get the system to properly play back 5.1 from ripped SACDs. Briefly seemed to work after connecting to HT receiver via HDMI instead of Ethernet and messing with a few settings.

Now when I play anything in Roon over HDMI, I get about second of playback followed by a few seconds of low-level white noise, and it keeps repeating like that.

I have power-cycled both the Core and the receiver. I have disconnected and re-connected the HDMI cable. I have toggled exclusive mode. When I connect the Core to the receiver via Ethernet, it plays back 2-channel content properly, but of course downmixes multi source content to 2 channels.

This has been incredibly frustrating. Any assistance would be greatly appreciated.

I think I figured out the problem – In my Mac’s midi settings, it was specifying the wrong sample rate – changed that and finally got uninterrupted output.

(Hope this helps someone else figure out this issue faster…)

As with most things in hardware and software all the stars and planets must align to make things work.

glad you got it sorted… HDMI is a can of worms at the best of time.

So it seems.

It would sure be a lot easier to manage all of this if Roon could send multichannel content over Ethernet. Is there some non-negotiable hardware constraint that makes that impossible, or is it just a question of adding that capability at the software level?

I think its more down to the ability of the end point.

It can, and does - if the endpoint knows what to do with it.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.