Help a new user out

Core Machine (Operating system/System info/Roon build number)

MacBook Pro

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Description Of Issue

Signed up for the free trial yesterday, downloaded Roon and told it to make my MacBook Pro the core, it worked perfectly but today I closed the app and when I opened Roon back up and signed in I get “you’re already signed in” and that I can only have one core, I’m confused this MacBook Pro is the core so how can I sign back in?

You shouldn’t have to sign in to Roon every time you open the app. Did you try to go back as the directions say? If that doesn’t work you may have to force close the app and reopen.

1 Like

Try pressing the unauthorize button. This has solved the issue for a lot of users.


When I click back I end up in the “choose your Roon core” page, if I choose “find Roon core” it searches nonstop, if I choose “use this Mac” I get the page I posted on the first post, I tried force quit the app and restarted the MacBook but nothing.

That is if you have a Roon Nucleus or ROCK. You don’t, so it will search forever and not find anything.

I think there is a bug in Roon. Unauthorize as suggested and reauthorize.

That is what has worked for others.

1 Like

That actually got me in but now the Roon logo is stuck on trying to load the homepage but it isn’t loading

If it stays like this and won’t load restart your Roon Core or reboot your Mac.

1 Like

Ok did a reboot of the Roon app and did everything you guys told me, everything loaded back in, I’m new to this app and really enjoyed it yesterday but now I’m hoping that I don’t have to go through this everytime I close the app on my MacBook pro, is Roon usually this buggy?

I never bring down the machine Roon is on and I never shutdown Roon, so whether this is an ongoing problem, I couldn’t say.

Let’s see what happens.

1 Like

Hey @8bit,

Thanks for not only giving Roon a try, but also joining the Roon community - welcome!

I’m sorry that you ran into this issue. As it has been mentioned, choosing the unauthorize option should resolve this. Thanks for trying!

Is there anything else we can help with now? :slight_smile:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.