Help! Can't connect to Nucleus Roon Core after restart

Hi there,

So, I shut down my Nucleus today in order to move it into a new cabinet. Since restarting, however, I’m now no longer able to connect to the Nucleus Core. On the “Choose your Roon Core” screen, the status keeps cycling between “Ready”, “Connecting…” and “Connection Failed”.

My Roon Nucleus is connected via Ethernet cable to a Sky Hub, and via USB to the DAC in my Rega Saturn player. I’ve also tried connecting the Nucleus up with several different Ethernet cables, but this made no difference either.

I am able to access the Web Administration Interface (as well as the Internal Storage Drive I installed in the unit, using Windows Explorer), and have tried the following with no success:

  1. Rebooting the Nucleus.
  2. Restarting the Server Software.
  3. Reinstalling the OS.

Still no luck. The IP Address is set to DHCP and is set to the correct IP.

Anyone have any ideas? It was working fine until I turned it off and back on today.



tried a different ethernet port on the router/switch?

Hi @James_Knapman,

Since you can access the Web UI it seems like things are okay on the Nucleus itself.

What kind of remote device are you using? Have you tried rebooting the remote? Is this happening for multiple remote devices or just one?