Help diagnosing playback stopping on DietPi endpoint on Wifi [Solved - WiFi Dongle]

#1

Playback is stopping randomly several times a day on my Raspberry Pi endpoint. It’s connected via wifi using a USB wifi adapter (I thought this issue could be the internal Wifi, so I got an adapter with an antenna).

I’ve had a look at the servers logs and can’t make much sense of them. The remote will throw an error in orange but it’s not too helpful either.

The wifi seems to be holding strong with an uptime that doesn’t indicate connection drop outs. Good signal, and plenty of Rx/Tx speed. The pi is sitting about 6 meters from the AP and has clear line of sight. It’s a Unifi wifi network and the only other wifi endpoint I have is a Sonos Play:1 which performs brilliantly even on the other side of the house or outside through multiple walls (with a much worse signal).

04%20pm

I’ve been considering ethernet but its going to be a bit of work to do it neatly so I’d love a solution to getting it to work on Wifi.

#3

This is probably a long shot but what sample rate are the files you are playing? I recently swapped by (ubiquiti) access point from 40mhz bandwidth to 20mhz on 2.4Ghz and was unable to play high res files. Swapped back and all was fine. This surprised me, as I thought that 72 Mbps should be fine but apparently not for me. Might be worth temporarily changing your channel bandwith to see if it makes any difference?

#4

Thanks mate. I’ve changed it up to 40mhz and it seems less reliable now. Much lower transfer speeds in general and dropping out a lot more.

Now I’m wondering if someone at @support can take a look at my logs to shed some more light?

The zone seems to drop out and disappear altogether for a second and then come back, and hence stopping playback.

#5

Sorry, worth a shot! I guess that suggests some WiFi interference in the mix, though that could just be a red herring…can you temporarily cable it to eliminate this possibility? Otherwise, hopefully @support will help out.

#6

No worries. Yeah it’s looking like I might have to crawl under the house with a roll of cat 6 cable.

#7

Don’t get dirty before you try using a static IP.

(Noris) #10

Hello @jptaranto,

Thanks for contacting support, feedback is always appreciated! We can take a look at the logs if you want, I have enabled diagnostics mode on your account and the next time your Core is active, a report will be automatically sent to our servers. In the meantime though, can I please ask you for the following:

  • What is the exact “error in orange” that Roon is outputting?
  • Would it be possible for you to temporarily connect the DietPi via Ethernet to see if the playback is still stopping?
  • Is your Core also connected to the router via Wifi or Ethernet?
  • Is your Core on the same subnet as the DietPi (as in the IP addresses of the DietPi and the Core are in the same range ex.192.168.1.XXX)?
  • Have you tried setting a static IP address for the Core/DietPi to see if the dropouts still occur?

Please let me know when possible.

Thanks,
Noris

#11

Thanks everyone for responding.

  • The error in orange is the transport error, file loading slowing could indicate hardware problem or some such. Which does point to slow wifi doesn’t it? The other issues is a complete dropout of the zone for a few seconds as mentioned before.
  • I will try a temporary ethernet connection on the weekend.
  • Our topology involves Core > ethernet/1000fdx > switch > fibre/1000fdx > switch > ethernet/1000fdx > AP > wifi/2.4Ghz > Raspberry pi.
  • Everything is on the same subnet - 192.168.1.x
  • I’ve enabled a static ip for the raspberry pi. The unifi setup seems to always give the same devices the same IPs anyway. I’ll see how this go. The core already has a static ip.

I’m playing to the endpoint now. I’ll try a mix of mp3 and flac and see what happens.

(Noris) #13

Hello @jptaranto,

I just want to follow up with you here and ask if temporarily switching to an Ethernet connection has resolved the issue or if you are still experiencing playback issues on your DietPi. Can you please let me know? Thanks!

Regards,
Noris

#14

Been a little busy of late so I haven’t had a chance to test Ethernet.

I’m still looking for a reason why the Wifi is so unreliable on the Raspberry Pi vs say the Sonos Play:1. They both run off 2.4ghz with similar transfer speeds. One drops out routinely with large files (flac) the other never misses a beat.

Do the logs give you any information about drop outs?

(Noris) #15

Hello @jptaranto,

I have just received the report back from QA and unfortunately the logs have been inconclusive thus far as to pinpointing what’s going wrong here, but we will do some further analysis. QA has suggested that you try to use Ethernet and see if it is exhibiting the same behavior so that we can narrow down if this is a networking issue or a device issue. They also wanted me to ask you what DAC you have connected to the Raspberry Pi, it seems like a “Justboom” device but I wanted to confirm that with you if possible. Please let me know your reply to the above questions when possible.

Thanks,
Noris

#16

Hey Noris. Thanks again for looking into this.

It’s a JustBoom Amp HAT which has it’s drivers included as part of Diet Pi.

I’ll report back once I’ve had a chance to try ethernet. It might be a few days away.

(Mr Fix It ) #17

@jptaranto I don’t think thus far you have indicated the bitrate of the files when this occurs. I’ve got UniFi everywhere in the house and anything over 44.1 with WiFi even a few feet away on pi is hopeless. With lan based connections I can run my ropieee os based pi at up to dsd512 rates to my OPPO Sonica dac

Cat5 is fine for pi as it’s max is 100mbps for testing across the floor but if you run it under the house go with cat6 for the future.

#18

The OP did mention using a USB WiFi dongle - I have these on a couple of RPis and stream 192KHz without any problems at all, so should be possible, all other things being equal.

#19

@dhusky which dongles are you using? I’d love to try a new one. Could be quite a possibility the one I chucked on is just as bad as the onboard wifi.

Streaming 90% mp3, with the odd 24bit flac file thrown in. It’s much more unreliable with 44+ flac files.

There is a direct correlation with the microwave too. As soon as that thing goes on it drops out. A 5ghz dongle would be much better suited in the kitchen. I’m having real difficulty figuring out what chipsets work on the pi.

#20

I’m actually using 2.4Ghz dongles, Edimax EW-7811Un N150 Wireless USB - never had an issue with dropouts from them, previous RPi wifi was unusable. Not tried the 5Ghz variant though - I can see that might make more sense in a kitchen environment.

#21

Excellent, I’ll give one a go.

#22

This is probably asking the obvious, and apologies if it is, but have you checked for channel interference as well with something like the WiFi Analyser app?

#23

All good - yeah I have a few times now. I live in the bush so there are no other wifi networks to get in the way. So I ran it with the microwave on and did show massive interference on several channels. I think Unifi does this normally anyway and chooses the best channels as the AP was already using a channel without much interference.

#24

Wow, this Edimax wifi dongle seems to be doing the trick. No dropouts so far in the last few weeks. Thanks @dhusky!