Help getting to play HQP/Roon/Microrendu [Resolved]

Hey. I have a DSD only DAC (Lampi Atlantic). I had HQP with Roon integration running fine when connecting my server directly to my DAC. However, I then had issues with my server, had to download the OS again, lost settings, etc.

In the meantime, I picked up a MicroRendu. It is great, but is limited to DSD 128 until new firmware is available (soon). I have been playing DSD 128 with the Roon DSDP. However, I am having trouble getting HQP to work (with Roon integration). I am sure it is just a setting issue, but I need help with that.

Here is a screen shot of my HQP settings:

When trying to play music controlled by Roon, this is the signal path. Looks like it is playing PCM. not DSD. Here:

Any assistance will be greatly appreciated.

Clearly, PCM is being played. How do I get it to play DSD instead?

And, I do not have the Roon DSP engine enabled. I have been told that is ok, but I still do not understand why that is an option in HQP mode given that they both do the same thing.


Change the following:

  1. Turn off 2wire
  2. Change SDM Pack to DOP
  3. Change Buffer to Default

After the above go into the main HQPlayer screen and change the right drop box from Auto to SDM.

1 Like


I am not seeing right drop box with auto v. sdm choices.

Found it. Give me a sec.

Success!!! Thanks so much.

Would be nice if all the settings were on the settings drop box. Oh well, very excited that it is up an running again.

Thanks again for the help.

Iā€™m not clear how to use Roon, HQ player and microrendu together.

I have a mytek liberty dac.

I use roon and want to output to hqplayer via my microrendu.

I have the microrendu software set to roon and I can see microrendu on Roon. However, unclear as to how to output this to HQ player. Right now its going from microrendu to USB device. I have HQ player set to NAA and also see a listing for my mytek liberty.

Any advice appreciated.


Roon outputs to HQPlayer. HQPlayer via NAA to microRendu.

So you need to:

setup an HQPlayer zone in Roon and select it.

Configure the SonicOrbiter software in the mR to an NAA. Make sure the DAC connected to the mR is on with the USB input selected.

Configure HQPlayer Settings/Backend to NAA and Settings/Device to the mR. You might need to restart the mR and HQPlayer in order for it to find the mR on the network.

Configure HQPlayer output to a valid input for your DAC. If you are upsampling then give it 2-3dB of headroom using the HQPlayer configurable volume. I set Volmin to -16, Volmax to 0 and use 12 noon for -8dB of headroom, but I convolve room EQ which needs more headroom.

Press Play in Roon.

1 Like

Thanks. Works fine.